How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21706
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

hi i have a iveco daily 29l10 2.3 hpi on a 03 plate have

Customer Question

hi i have a iveco daily 29l10 2.3 hpi on a 03 plate
have had the odd starting isue with it even if its hot or from cold
plus when driveing injector light flashes and rev counter would stop working until i rev the engine high i say past 3000rpm then light would go out and rev counter comes back on, when the light flashes it seems like there is a loss of power, and more recently just before the above fault happens the van seems to miss or just one spluter any help would be great
recently had fuel filter as the last one for some reason had got water in it
Submitted: 3 years ago.
Category: Car
Expert:  Shantal-Mod replied 3 years ago.
Hello,

I'm Shantal and I'm a moderator for this topic.

We have been working with the Experts to try to help you with your question. Sometimes it may take a bit of time to find the right fit.

I was checking to see if you had already found your answer or if you still need assistance from one of the Experts.

Please let me know if you wish to continue waiting or if you would like for us to close your question?

Thank you,

Shantal
Expert:  Matt replied 3 years ago.
Hello

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;
Airflow meter
Crank position sensor
Cam position sensor
O2 sensor
Throttle pedal position sensor


Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Related Car Questions