How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Car
Satisfied Customers: 7126
Experience:  Automotive diagnostic tech
29331485
Type Your Car Question Here...
Greg is online now

hdi 2.0 auto from cold i go about 1 mile then the snow & sport

Resolved Question:

hdi 2.0 auto from cold i go about 1 mile then the snow & sport mode lights start to flash so i have to stop the engine then start it again then it is usually 9 out 10 alright
Submitted: 3 years ago.
Category: Car
Expert:  Greg replied 3 years ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,

This could be one of many issue with the trasmission management system .

The only way to find what is malfunctioning is to be hooked up to a diagnostic scan tool ,
this tool will do a scan of the system and see what has malfunctioned and give you a code, from the code you will then know what has to be checked and then repaired or replaced .

This could be anything from any of many sensors .

Don't think you have a mechanical problem but most likely a sensor malfunction ,

A wheel speed sensor,vehicle speed sensor, the mode switch malfunction could cause thisbut a scan is needed so no sensor or parts are replaced that don't need replacing .

If you need further assistance with this issue then please let me, get back to me with the reply button and not the poor or bad service, this way i can get back to you or suggest another expert if needed.

Kind regards Greg
Customer: replied 3 years ago.

come to think the speedo does keep stopping and then starting again would this indicate the speed sensor

Expert:  Greg replied 3 years ago.
Hi .

Yes this will be the problem a intermittent VSS vehicle speed sensor.

Have this checked and repaired and all system cleared reset .

Good work ;-)

Rgds Greg
Greg and other Car Specialists are ready to help you