How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Technician
Category: Car
Satisfied Customers: 39198
Experience:  Tech Expert
9261905
Type Your Car Question Here...
Mike is online now

fiat stilo estate 2003 drives fine, but than cuts out when

Resolved Question:

fiat stilo estate 2003 drives fine, but than cuts out when engine gets warm. Have replaced crankshaft sensor, but no joy. MIL (engine) light comes on, and car loses power and comes to a stop.
ran diagnostic scanner two DTC's came up.
P0335-crankshaft position sensor A circuit malfunction
P1687 Throttle driven [signal implausible]
Any idea what could be the solution to this problem.
Submitted: 3 years ago.
Category: Car
Expert:  Mike replied 3 years ago.
Hello and Welcome..

Exactly which engine do you have?

A full reg no. would be good too if you can..

Do you have current fault codes... since the last breakdown...

Rgds, MIKE.....................................
Customer: replied 3 years ago.

REG WP03 HNT

STILO MULTI WAGON 1.6 16V Active 5dr [AC], manual transmission

mechanic replaced crankshaft sensor, car ran fine, But than engine light came on. I let it cool down, and than car runs fine until it gets warm and than cuts out. I have deleted the two DTC (P0335 & P1687) from the ECU. The ECU was tested, and found not to be at fault. I was advised by the mechanic may have to take it to fiat or get an auto-electrician.

ran diagnostic scanner two DTC's came up.
P0335-crankshaft position sensor A circuit malfunction
P1687 Throttle driven [signal implausible]

Expert:  Mike replied 3 years ago.
Hello again - - Im sorry I dont have your name..

Im sorry I was off yesterday...

Ok - the first code you have is yes for the CPS- but not necessarily the component - you need to carefully inspect the wiring connector in its loom - and the wiring right back to the Ecu...and then too, if nothing is found, the pins on the Ecu. I dont actually think you have any issues there - crank sensor fault codes can show when not a problem... but do check as above.

The real issue is more likely with the second code - and thats for the throttle body -circuit ...strictly from the book : Motorized throttle(plausibility)... Motorized throttle(stop learn) Faults are related to the throttle body/wiring connections - so check these again - espeically the connections as they do give trouble on these...

You might have a faulty throttle body..P 1684 is a fault during self learning of throttled body (low battery or plausibility) Have the battery / alternator - charge rate checked...and check the integrity of the wiring inc earths.

Now - once you have gone through all the above - try a Throttle Body ( motor ) re learn procedure... this is important on these models - to correct running / cut out issues etc -

The procedure is as follows for you:

1) switch ignition on (DONT START) for one minute
2) switch ignition off one minute
3) start car (DONT TOUCH THROTTLE AT ALL) and let idle until cooling fan cuts in (10-15mins)
4) switch off
5) repeat step 1
6) repeat step 2

...

Working through as above you should get this cured.

Im very pleased to have helped you - Do let me know if you need anything more --

*** Meanwhile - - >>>> Please do click on the "OK/ Excellent ratings" for me - Thank you in advance for that...

You can and are most welcome to get back to me anytime you might need - clicking the OK ratings does not close you out at all..

Kind Rgds, MIKE.
Mike and other Car Specialists are ready to help you