How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ross Your Own Question
Ross
Ross, Diagnostic and repair technician
Category: Car
Satisfied Customers: 1180
Experience:  Licensed diagnostic and repair technician
70583916
Type Your Car Question Here...
Ross is online now

citreon dispatch 2002 hdi always runs great.in last few months

Customer Question

citreon dispatch 2002 hdi always runs great.in last few months somethimes wont start.2or 3 minutes later starts and runs fine.never cuts out when driving.fuel pump in tank runs.power to heather plugs ok.power to solenoid on rear of injector pump ok.plenty fuel to commonrail.but will not fire.i think it has2 be an electrical problem? or a selonoid all fuses o k.hope you can shed some light on this
Submitted: 2 years ago.
Category: Car
Expert:  Ross replied 2 years ago.
Ross :

Hello and thanks for trusting me to help you today. I am a licensed diagnostic and repair technician, I look forward to working with you.

It sounds like you have checked a lot of the basics which is great, it doesn't leave much other than the electronics and i think your correct in suspecting this. As the fault is probably within the engine management system sensors, access to a diagnostic system will be vital to confirm any faults for sure, but from experience the crankshaft position sensor sounds like a primary suspect to me.

The crank position sensor is a very common failure, and it is one of the few sensors that will prevent the engine from starting as it uses this to know when to inject fuel on each cycle. I would start if possible by checking for a signal from this sensor on diagnostics if possible, this also often doesn't show any fault codes as having no signal is not thought to be a fault, it simply thinks the engine is not turning. If you don't have access to diagnostics this sensors would be the first to change or swap for a known good sensor.

Ross :

I hope I’ve provided the information you were seeking. If you need more help, please use the reply tab to continue our conversation. If you do not require further assistance, kindly rate my service. Thank you, Ross.

Expert:  Ross replied 2 years ago.
Our chat has ended, but you can still continue to ask me questions here until you are satisfied with your answer. Come back to this page to view our conversation and any other new information.

What happens now?

If you haven’t already done so, please rate your answer above. Or, you can reply to me using the box below.
Customer: replied 2 years ago.

hi Ross.and thanks.if the crank position sensor is faulty.i would think the van would mabye misfire or cut out.whenit does start.it runs perfect.what relays are involved in the circuit,

Expert:  Ross replied 2 years ago.

The crank sensor will cause this problem so dont rule it out at this point.

Unfortunately i have no diagrams for this model showing the relay locations but from memory there are no individual relays which would effect the engine, there will be a main relay, its a small control unit in the engine bay, this will however usually stop the glow plug light coming on if its causing the problem as it controls the main start up functions. This one may well be worth looking at, often if its sticking you can give it a tap and try to start it. I know the earlier models of this engine has this mounted just beside the battery, but on this later model i can't remember where it is located.