How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Kelly Your Own Question
Mike Kelly
Mike Kelly, Auto Service Technician
Category: Car
Satisfied Customers: 5470
Experience:  17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.
19374685
Type Your Car Question Here...
Mike Kelly is online now

My '92 Bentley Brooklands (...PCH46138) has a Bosch MK Motronic

Customer Question

My '92 Bentley Brooklands (...PCH46138) has a Bosch MK Motronic injection/ignition system I think. It starts fine from cold. However, after about 30 secs to one and a half minutes the revs drop to stall and sometimes it cuts out completely! When you turn off the ignition and start again it usually warms up nicely. But not always and it can take up to 5 goes to get her running correctly. Then she's fine for as many miles as you want to drive her that day! Warm start is perfect. Last year I took her to Nigel Sandell in Isleworth but he couldn't solve the problem, even though he changed almost every sensor, the alternator and the fuel pump! Any ideas? I've been thinking of testing her myself but I can't locate a Bosch 9893 adaptor to fit in series on the EHA. Please help! Gor***** *****
Submitted: 2 years ago.
Category: Car
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Mike Kelly replied 2 years ago.
Hello, welcome. My name is***** will do my very best to assist you with your question. I apologize if you have been waiting long for a response.
From what you are describing the issue that you are having is consistent with one or more fuel injectors not priming up correctly which in turn results in your issue. What i would suggest as a next step is to have the fuel injectors balance tested, this will show the bad ones.
Mike Kelly, Auto Service Technician
Category: Car
Satisfied Customers: 5470
Experience: 17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.
Mike Kelly and other Car Specialists are ready to help you
Customer: replied 2 years ago.

Not the injectors, I think They've been cleaned and balanced. I'm looking at the EHA current right now to see if that suddenly changes during warm up. So not very helpful I'm afraid. How come I was charged £27 when I only agreed £11 in the first instance? Any chance of a refund? Thanks for your interest, Gordon