How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Szczygiel Your Own Question
Greg Szczygiel
Greg Szczygiel, UK Car Mechanic
Category: Car
Satisfied Customers: 12
Experience:  Vehicle technician and electrician currently working in reputable independent garage in UK. Fully acredited ATA diagnostic technician.
82566532
Type Your Car Question Here...
Greg Szczygiel is online now

i have just put in a new pump in washer still not

Customer Question

i have just put in a new pump in washer still not working
Submitted: 2 years ago.
Category: Car
Expert:  Greg Szczygiel replied 2 years ago.
and welcome to Just Answer,my name is ***** ***** I'm looking forward to find the answer to your question.
To find the cause washer pump not working I recommend to check fuse no 3 in engine compartment fuse box.
I assume the rear screen washer is also not working.
If the fuse is good, some more check will have to be done to find out if the problem is in wiring, like open circuit or faulty controls.
I hope this helps.
Let me know if more info required.
Greg
Greg Szczygiel and other Car Specialists are ready to help you
Customer: replied 2 years ago.

thanks lads I new it was some thing simple like a fuse put some one said it would not be one under the frount fuse box sued have gone with my gut feeling . thank you very much wipers working and I am a happy man

Expert:  Greg Szczygiel replied 2 years ago.
You are welcome.
Customer: replied 2 years ago.

any of you lads have a plastic trim for put fog light fiting drivers side I seem to have broken it when fixing the pump thanks