How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21707
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

Suzuki hayabusa 1999. Wont start has warning light FL in red.

Customer Question

Suzuki hayabusa 1999. Wont start has warning light FL in red. with code 100. All electrics work starter motor works but engine wont ignite
Submitted: 1 year ago.
Category: Car
Expert:  Matt replied 1 year ago.
Hello there's no code 100 on these if you get a C00 then this means there are no codes to be read 1st thing worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V If thats OK then check to see if you're getting spark check for spark by removing one of the spark plugs and plug it back into its coil and rest it on the metal of the engine ( DO NOT hold it on place by hand) then have your assistant turn the engine over whilst you watch the plug. It should give a fat blue spark at regular intervals. If not then check that there's power to the coil using a meter. If there’s 12V at the pack but no spark then check the ECU power supply (fuse and relay) and also the connections to the crankshaft speed sensor. If there is a spark and its still not starting then its likely that the ECU isn't opening the fuel injectors, if the injectors are working you can hear them click - its difficult to hear them with background noise so use a long screwdriver like a stethoscope, placing the handle end in your ear and the metal tip against the body of the injector whilst your assistant turns the engine over.If you can't hear anything check the ECU power is present by measuring voltage at the fusebox and on its relay socket if OK then check the connections to the crank speed sensor and consider replacing this sensor if the wiring / connections look OK If the car will start using a squirt of quick/ easi start into the intake then this confirms the problem is lack of fuel
Customer: replied 1 year ago.

thank you ill try these steps in order tomorrow

Expert:  Matt replied 1 year ago.
no problemBear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. so if my answers have been helpful please rate my answer.
Expert:  Matt replied 1 year ago.
Hi

do yuo stil need help?

Related Car Questions