How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Car
Satisfied Customers: 7093
Experience:  Automotive diagnostic tech
29331485
Type Your Car Question Here...
Greg is online now

Audi s3 epc light when turning and accelerating at the same

Customer Question

Audi s3 epc light when turning and accelerating at the same time does not do it when I don't accelerate!? 18047,18010,16795 need help urgently car is unsafe at the moment!!
Submitted: 1 year ago.
Category: Car
Expert:  Greg replied 1 year ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,
18047 is your APP sensor malfunction..
18010 Voltage low from battery to ECM
16795 is your secondary air injection incorrect flow detected .
I would first check the battery connection as this will set off other codes .could be your ground cable from the battery to the chassis and engine block. typical issue on this car.
This is why when you turn a corner and try to accelerate will not
do to losing power ,check engine mounts to much movement of the engine put stress on wiring harness
Looks sure to be this as seen it many times .
Then if needed please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed.
Your deposit does not pay me until the answer is rated in a positive way,
Not rating or a bad rating does not constitute a refund.
If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .
Kind regards Greg.
Customer: replied 1 year ago.
Hi Greg thanks for the reply it has started to do it from like 2mph now so I can see it being because of movement due to turning I've checked the grounds already and they are clean and tight it will only come on if I try to accelerate while turning not if I turn and don't accelerate nobody knows how to fix this fault it's puzzled most people if I could get a conversation about it that would be great
Expert:  Greg replied 1 year ago.
Hi .
Very hard to say not being there at the car with diagnostic scan tool.
But now i would point towards possible bad pedal sensor which can be checked with a scan tool in live mode .
18047:
Accelerator Position Sensor 1/2 (G79/G185): Implausible Signal.
Possible Symptoms
Malfunction Indicator Light (MIL) ON
Reduced Engine Output
Possible Causes
Wiring and/or connections faulty
Faulty ECM
Faulty Accelerator Pedal
Possible Solutions
Check Measuring Block Readings for Accelerator Pedal
Check Voltage Signals from ECM to Throttle Pedal (see factory repair manual)
Check Wiring and Connectors from ECM to Accelerator Pedal
Special Notes
There are 2 sensors in the accelerator pedal, both should increase in the same direction as the accelerator is pressed but they have different scales. This means one counts from 0 to 100, while the other one counts from 0 to 50.
Rgds Greg
Customer: replied 1 year ago.
Why does this only happen when I turn though I don't think that's correct as the live data reads okay?
Expert:  Greg replied 1 year ago.
Then it has to be a connection issue as said, or a bad ECM
check if there is a reflash for this issue at Audi/VW.
Greg
Customer: replied 1 year ago.
It cost me £27 for someone to read the same stuff I did online and post it as a message not very helpful
Expert:  Greg replied 1 year ago.
How do you mean ,Its not cost you anything unless you rate, and if not happy you can request a refund but don't rate . Greg.