How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Car
Satisfied Customers: 7129
Experience:  Automotive diagnostic tech
29331485
Type Your Car Question Here...
Greg is online now

Kia picanto 2009 basic model no remote door opening so no battery

Customer Question

kia picanto 2009 basic model no remote door opening so no battery in key asm intermittantly fails to start , engine turns over, garage checked with computer , no errors recorded and said he could not fix car without error message, we drove it home yesterday when it started , but today we still have the problem
Submitted: 1 year ago.
Category: Car
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 1 year ago.
problem still present, car started ok this morning, and again mid morning, would not start after lunch while out shopping, so I kept turning engine over and tried pressing accelerator , didn't work first 3 times of trying. , tried it again, it eventually tried to start, but didn't quite make it so i assisted with accelerator , eventually started and i drove home. stopped and started at home and it was okay again.
Expert:  Shantal-Mod replied 1 year ago.
Hello,
Thank you for getting back to me and providing more information. We will continue to look for a Professional to assist you.
However, should you wish to close your question and reverse your charges at any time please let me know.
Thank you for your patience,
Shantal
Expert:  Greg replied 1 year ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,
Hi .
Do you have any warning lights on the dash when the engine is running like the check engine light.
As i understand the key fob is not working ,and car will not start .
you fitted new battery in the keyfob and then it worked but next day would not start the engine .
Do you have a spare working key .did you try this .
you may just have a faulty keyfob.
Greg
Customer: replied 1 year ago.
Hi Greg, I don't know where you got idea re key fob, my kia does not have remote central locking , therefore there is no battery in key fob, there are no error indications on dashboard, engine whirls round on starter motor , but doesn't start, but I will update you with the way I have just got the car to start after giving up on it for 2 days, we had no spark at plugs and i was going to call rescue service out to tow it to garage. As its got a computer management system I thought maybe a total power on reset would fix it - nothing to lose. so i disconnected car battery totally, left for 10 minutes, reconnected , tried car and it burst into life, I drove it to garage for further examination tomorrow (Monday) stalled it twice ( feet too big for pedal space) car started every time straight away. Thanks for your time Greg.
Expert:  Greg replied 1 year ago.
Okay wonderful. But the problem is not solved as this is most likely to happen again . What happened is a sensor Like a (crankshaft sensor) may have intermittently failed .. (example)so when you disconnected the battery it reset itself back to factory settings . So now if the crankshaft sensor fails again you are going to have the same problem ,I say crankshaft sensor as this is the most typical issue for the problem you are experiencing .So a scan tool is needed to get into the management system to check for malfunction codes .Ones you have the codes you will then know what is the problem .Tip no codes will as said most likely be the crankshaft sensor .. Still need help then please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed.Your deposit does not pay me until the answer is rated in a positive way,A bad rating does not constitute a refund.If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .Kind regards Greg.
Greg, Technician
Category: Car
Satisfied Customers: 7129
Experience: Automotive diagnostic tech
Greg and other Car Specialists are ready to help you
Customer: replied 1 year ago.
Greg, one time when wife had problem with car starting it came up with code, she drove to garage and it indicated crankshaft sensor, so garage ordered and fitted it, guess what car still failed to start the next day. Car now in garage that has access to Kia engineers (Kia franchise dealership).
Thanks for your input, would you like to know the problem and fix when I get told it. David
Expert:  Greg replied 1 year ago.
Hi David .
Yes sir that would be nice if you would let me know .
Now if they do a new scan for codes and find the same code for the
crankshaft sensor , then its most likely to be a connection ,wiring or ECM issue.
But this is only what could be with out hooking up a good scan tool and checking the system .
Kindest regards Greg.
Thank you David!!
Customer: replied 1 year ago.
Hi Greg,
Car is still in KIA garage they can't fix it either. It still is not indicating an error on scans, but it regularly doesn't start for the either.
We have 2 options sell it at auction ( don't like that idea , but friends suggest it) or scrap it. We have had enough worrying about it.
Oh well thats life, some you win , some you lose.
David
Expert:  Greg replied 1 year ago.
Hi David . This is Sad when this happens but does . I hate it . but did they every think of reprogramming or trying another ECM . Greg