How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21993
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

I have a corsa diesel which idles rough with blue/white smoke

Customer Question

i have a corsa diesel which idles rough with blue/white smoke out exhaust but will not rev up at all
Submitted: 1 year ago.
Category: Car
Expert:  Matt replied 1 year ago.
Hello
to get blue smoke out of the exhaust then it must be burning oil ?
The first thing I'd check is the crankcase pressure relief valve (PCV) these are sprung loaded and are only meant to 'burp' excess pressure every now and then. The exiting gas is piped back to the inlet, however should the valve stick open then the engine tends to suck the air out of the crankcase all the time and this carries oil over with it.
If you remove the air intake pipe and look inside where the crankcase breather is plumbed in you may find evidence of oil.
If you do find oil replace the valve. If this is all OK then its possible that the valve stem seals are past their best and are drip-feeding oil into the intake. These can be replaced without removing the head by a competent garage in half a day or so
Also check inside the intake just after the turbo for any signs of oil as this would be an indication that the turbo oil seal is starting to fail and a replacement / rebuilt turbo may well be required. Have a feel of the turbine wheel - there should be no play radially at all - but a little bit of axial / end to end float is normal
Matt and other Car Specialists are ready to help you
Customer: replied 1 year ago.
ok looked fine to me but i have no acceleration at all ticks over but when press accelerator nothing happens, new fuel pump and cam sensor fitted.
Expert:  Matt replied 1 year ago.
OK I'd check the compressions across all cylinder too as they should all be within 10-15 psi of each other