How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21623
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

I have a vitara 1.6 2002 it developed poor running,almost a

Customer Question

i have a vitara 1.6 2002 it developed poor running,almost a miss on pick up with black smoke coming out the exaust all four plugs black i got it pluged in and it came up with egr valve fault tested wiring to egr all ok so i fitted second hand egr still not fixed i took old one apart thinking i would find it stuck but it was free checked coolant and air temp all ok ambient also ok lambdas are getting voltage i disconected each sencor one at a time thinking it give a default setting and i would work out whitch was at fault nothing found i cant find any air leaks and i drained and put new petrol in no good it still comes up with egr after a run please help
Submitted: 1 year ago.
Category: Car
Expert:  Matt replied 1 year ago.
Hello
Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:
http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp
You can also try spraying some water on the coil pack with the engine running. It is possible the coil is faulty and causing the misfire. If you see sparks arcing with the water, then replace the coil.
I'd check the condition of the injector plugs / connections as this could be a lean misfire if an injector isn't firing properly - the best way to check this is with a 'noid' light
http://www.noidlight.com/
Then check all the connections to the engine sensors one at a time, remove each one and examine for signs of corrosion or damage and a squirt of contact cleaner ( not WD40) will also help.
This could be an airleak after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for and leans the engine out causing rough running.
Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.
The best way to locate a leak is to have the engine running and warm and then spray lighter gas around each joint in turn. If the engine rev's up you've found your leak.
Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.
It’s also worth getting the fuel pressure checked as if this is low due to a blocked filter or faulty regulator or even a poorly pump will all result in insufficient fuel being delivered to the engine
Expert:  Matt replied 1 year ago.
Hi
do you still need help?
Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

Related Car Questions