How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21618
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

THis is a Vauxhall Signum Elite, 1.9 diesel, 56 reg. 99% of

Resolved Question:

THis is a Vauxhall Signum Elite, 1.9 diesel, 56 reg. 99% of the time it drives perfectly. then for no reason the engine cuts out. This happens mainly when driveing about town and when slowing down, has never yet happend on the Mway.
The engine do's not restart if the car is still rolling with ign on, but restarts immediatly if the placed in N, allowing the engine to stop turning. And the ign is turned off and back on the engine then restarts with the starter motor. Anybody help????
Malcolm
Submitted: 1 year ago.
Category: Car
Expert:  Shantal-Mod replied 1 year ago.
Hello Malcolm,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Matt replied 1 year ago.
Hello This sounds like an electrical actuator or sensor at fault .Usually when you can cycle the ignition key on / off and then restart the engine and the fault is gone temporarily this indicates that this is an electrical component causing this issue. This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;Airflow meterCrank position sensorCam position sensorO2 sensorThrottle pedal position sensor unplug each in turn and use some switch / contact cleaner spray on the pins to ensure its all grease / dirt free Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40 and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.
Expert:  Matt replied 1 year ago.
Hido you still need help?Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21618
Experience: BEng hons Mech engineering, in auto industry 22 years
Matt and other Car Specialists are ready to help you

Related Car Questions