How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 22145
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

I have a 2001 2.0 ts alfa spider which has been restored at

Customer Question

I have a 2001 2.0 ts alfa spider which has been restored at great expense but have one problem left to sort,the speedometer will only register between 20 & 40 mph,I have changed the head but made no difference, any clues.
Submitted: 1 year ago.
Category: Car
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 1 year ago.
In have not been able to resolve the problem and would ask that you continue to keep trying to find me an answer.
Expert:  Shantal-Mod replied 1 year ago.
Hello,
Thank you for getting back to me. We will continue to look for a Professional to assist you.
However, should you wish to close your question and reverse your charges at any time please let me know.
Thank you for your patience,
Shantal
Expert:  Matt replied 1 year ago.

Hello

I'd start by checking the condition of the VSS (vehicle speed sensor)

The sensor is on top of the box just above where the o/s driveshaft enters the gearbox

disconnect it , clean the pins with contact cleaner and check the wiring for damage

if this is all OK then replace the sensor

Expert:  Matt replied 1 year ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you