How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 22255
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

I have an old Volkswagen Transporter 94 model but I've been

Resolved Question:

I have an old Volkswagen Transporter 94 model but I've been doing up it's got round to the engine and every now and again it will start and it will run for a while then when I go to restart it won't start up it just turns over and over but won't fire could you give me some advice please on what to look for and where in this model
Submitted: 1 year ago.
Category: Car
Expert:  Matt replied 1 year ago.

Hello

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:

http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Matt and other Car Specialists are ready to help you