How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Car
Satisfied Customers: 21860
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Car Question Here...
Matt is online now

I have a nissan almera 2005 diesel it is showing the

Customer Question

Hi i have a nissan almera 2005 diesel it is showing the malfunction light and struggles to go past 30 mph.
Submitted: 10 months ago.
Category: Car
Expert:  Matt replied 10 months ago.

Hello

as you have the light on then by far the quickest route to repair is to plug a scan tool into the car and pull off the code

as this will point to the fault

however as you have a lack of power then consider changing the fuel filter as if this partially blocked this will reduce pressure at the pump

If OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

Also have a feel around with your bare hands with the engine running to see if you can feel any escaping gas under your touch. Another method is to use a soap and water solution sprayed onto any suspect areas - if there's a leak it'll bubble up with the engine running

Also check that the vacuum hose running to the dump / turbo bypass valve is intact with no leaks as if the dump valve is opening prematurely you'll be losing all your boost

If this is OK then remove the high pressure intake hose after the turbo and have a feel of the turbine wheel - there should be no play radially at all - but a little bit of axial / end to end float is normal

one other possibility is that the wastegate actuator spring has gone soft so allowing the wastegate to open prematurely - if your actuator has a threaded end you can increase the preload on it to see if this improves things otherwise these units are quite cheap compared to a new turbo so it may be worth trying a replacement