How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Computer System Tech
Category: Computer
Satisfied Customers: 11551
Experience:  11 years experience
13568747
Type Your Computer Question Here...
Russell H. is online now

I am using UBUNTU 12.04 LTS and want to upgrade to 14.04.2

Customer Question

I am using UBUNTU 12.04 LTS and want to upgrade to 14.04.2 LTS. Thing is I run an old piece of software which will only run on superseded versions of Windows. For this I use the Oracle VM Virtual Box. How can I upgrade and be sure the Virtual Bow will still run the software?
Regards
Roger
Submitted: 2 years ago.
Category: Computer
Expert:  Russell H. replied 2 years ago.
Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question. I think that if Oracle VM Virtual Box will run on Ubuntu 14.04.2, then you should have no trouble. That is, providing that the hardware used is not distinctly different - e.g. a SATA hard drive where formerly you used a EIDE hard drive with the old piece of software, or similar gross differences in hardware type.If you are, as I would guess, just upgrading a computer's installed Ubuntu version, rather than upgrading the hardware of the computer or changing computers as well as changing Ubuntu versions upward... then there should be no problem. (Except for, as before, the caveat on the VM Virtual Box itself being compatible with the new Ubuntu version and running on it.)
Russell H. and other Computer Specialists are ready to help you
Customer: replied 2 years ago.
Thanks much. I just want to upgrade my computers version of Ubuntu, not upgrade the software. Are you saying that if my version of the Oracle emulator is compatible with Ubuntu 14.02 it should also be compatible with Ubuntu 14.04?
Best
Roger
Expert:  Russell H. replied 2 years ago.
I did not hear Ubuntu 14.02 mentioned before - do you mean 12.X and was that a mis-typing? - but yes, major version compatibility (with 14.X) should be enough, for whatever version of Oracle VM you want to use. (With specific information on versions confirmed, I could offer a more certain opinion.)
But (to cover all the bases on this statement), compatibility of the subject version of Oracle VM, with Ubuntu 12.X, does not prove compatibility with Ubuntu 14.x... it just makes it slightly more likely than not.