How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric
Aric, Technician
Category: Consumer Electronics
Satisfied Customers: 44442
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
24739752
Type Your Consumer Electronics Question Here...
Aric is online now

My son has a Sur Badger head , he's touring right now

Resolved Question:

Hi,
My son has a Sur Badger head , he's touring right now in the Netherlands with no internet and he has drastically reduced output .
It's not dead, there is signal, no noise or popping , just massively reduced output.
Has done as much troubleshooting as possible, established it isn't cables definitely head.
regards
Phil
Submitted: 1 year ago.
Category: Consumer Electronics
Expert:  Aric replied 1 year ago.
Hello and sorry you're having problems. Offhand, anytime the output is massively reduced like this, it would be a good start to replace the Input and output tubes in the unit, since a single tube being weak/low spec can cause this problem. This is the most likely and common cause of this problem. However, can you tell me how old the head is, and when the tubes were last replaced (if at all)? Feel free to reply back if you need more help, or want to reply back with more details. It does not cost you anything more to reply back once you've rated. Please do rate me positively (at least 3 STARS) and I will continue with you until this is sorted. The positive rating ensures I am credited for my work.
Expert:  Aric replied 1 year ago.
Also there are several models of Badger head (example: 15, 30 etc.), can you tell me which one your son has as well- if you need further assistance?
Customer: replied 1 year ago.

Are you seeing my replies?

Expert:  Aric replied 1 year ago.
No, there isn't anything else posted on this page. If you scroll up the page you will see all replies. Could you please resend them?
Customer: replied 1 year ago.

Must be a glitch in the system, here goes;

The head is approx 14 months old purchased new from Thomas and used continuously alternating with a Divided by 13.

Not sure if he's changed the valves , probably.

replies are slow from Rich as he's rehearsing and has no internet. Could we keep this thread open while I gather info please

many thanks

Expert:  Aric replied 1 year ago.
Thank you for the reply. Yes the dialogue remains open even once you rate my service- it doesn't close. You can reply back at any time. The valves would be the first and most likely culprit, if he's already changed valves and still has the same issue, then we're looking at something hardware related in the amp (cold solder joint on one of the power tube sockets is the next likely culprit). Feel free to reply back if you need more help, or want to reply back with more details. It does not cost you anything more to reply back once you've rated. Please do rate me positively (at least 3 STARS) and I will continue with you until this is sorted. The positive rating ensures I am credited for my work.
Customer: replied 1 year ago.

No probs, I'll rate you. It's a Badger 30.

I'll be back when I hear more , many thanks

Expert:  Aric replied 1 year ago.
You're welcome. If he hasn't already replaced the valves, we're looking at 2 x EL34 and 3 x 12AX7 for the tube lineup.
Aric and other Consumer Electronics Specialists are ready to help you

Related Consumer Electronics Questions