How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nick H. Your Own Question
Nick H.
Nick H., Hobbyist
Category: Digital Cameras
Satisfied Customers: 8276
Experience:  Working with Digital Cameras for the last 5 years.
63271161
Type Your Digital Cameras Question Here...
Nick H. is online now

I have a HCV10 camcorder that is about a year old. I have used

Customer Question

I have a HCV10 camcorder that is about a year old. I have used it three times. I wanted to use it today and plugged it in to charge last evening. This morning it had not charged. I have tried several times today to charge it and tried using a different USB cable once and charging from the computer another time. However nothing works. When I plug it into the power source the charging light flashes for a while but then goes off. When I try and turn on the power the camera makes a slight noise but nothing happens. Any ideas what the problem is and how to solve it?
Thanks
David
Submitted: 4 years ago.
Category: Digital Cameras
Expert:  Nick H. replied 4 years ago.
Hello David, and thanks for your question. My name is Nick and I will help you today.

It seems like a battery problem. The battery could be faulty. You can try to order or go to a camera / electronic store and test with another working battery. See if it will work.

If it worked, buy a new battery.

If it does not, then the Camcorder charging port is not working. You should contact Camera's manufacture to get it repaired IF THE CAMCORDER IS UNDER A YEAR.

Most likely the battery is faulty. We should try with another working battery first. See if your camcorder will charge.

If this method did not work or you need more help, please use the reply tab to continue our conversation. If you do not require further assistance, kindly rate my service. Thank you!

 

Nick

Customer: replied 4 years ago.

Hi Nick,


Thanks for that response. I had considered it may be the battery however the camera doesn't work when plugged into a power source. It should, even if the battery is dead, shouldn't it?


David

Expert:  Nick H. replied 4 years ago.
David,

That is mostly true. Please try to remove the battery. Connect your Camcorder to Power source. Does it turn on?