How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Technician
Category: Digital Cameras
Satisfied Customers: 5359
Experience:  10+ yrs. experience working on all forms of electronics and cameras both film and digital.
46422908
Type Your Digital Cameras Question Here...
Richard is online now

On my Canon EOS 500 the AE lock does not appear to work - the

Resolved Question:

On my Canon EOS 500 the AE lock does not appear to work - the * symbol never appears. Is this a common problem?
Submitted: 2 years ago.
Category: Digital Cameras
Expert:  Richard replied 2 years ago.

Hi. My nsme is Rick and I am a digital camera professional.

I would be happy to help you with this. Can you do the following and tell me what happens.

Lets remove the battery from the camera and then press and hold the power (on/off) button (or slide switch to on) for 1 minute. Than release the button, put a fully charged battery back in and see if it fixes it. . While you have the battery out clean the terminals in the compartment and also remove the storage card if you have one in the camera. You may also want to change the card if you have another one.
Customer: replied 2 years ago.
Hello
Thanks for reply
I've tried that but nothing happened. Going to try and leave it overnight - charging a battery up even more.....
Expert:  Richard replied 2 years ago.
OK let it charge overnight and see if it helps. I don't think it will make a difference but let me know if it helps.
Customer: replied 2 years ago.
No that didn't do anything
Expert:  Richard replied 2 years ago.
OK Andy, thanks. I have seen this before on this camera but it is not a common problem. What has happened is that the circuit on the cameras main control board has developed a short and this is what is causing the AE not to work. If your camera is less than 1 year old the repair for it will be done by Canon under the warranty. If not then it will cost you about $125 to have the board replaced locally and about $50 more to have Canon do it.
I am sorry for the bad news but if I can help further with this please let me know.
Customer: replied 2 years ago.

ok thank you

Expert:  Richard replied 2 years ago.
You are very welcome Andy. Please do the ratings and do have a great day.
Richard and other Digital Cameras Specialists are ready to help you

Related Digital Cameras Questions