How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Technician
Category: Digital Cameras
Satisfied Customers: 11412
Experience:  Working with digital cameras & questions for nearly 8 years.
13568747
Type Your Digital Cameras Question Here...
Russell H. is online now

eos600D unfortunately my husband has developed the dreaded

Customer Question

eos600D unfortunately my husband has developed the dreaded Als11111 and his camera has gone beserk too cannot access menu even. when it is switched on portrait landscaoe etc: it just beeps as if on timer then clicks twice and then nothing
Submitted: 3 years ago.
Category: Digital Cameras
Expert:  Russell H. replied 3 years ago.
Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

Try removing the batteries, and leaving the camera on a (dry, non-humid, non-dusty) shelf for overnight. Then put the batteries back in and try the camera again.

Then try cleaning the terminals in the battery compartment, after removing the batteries, first by rubbing off with a fresh pencil eraser, then by wiping the terminals off with cotton swabs moistened in rubbing alcohol, then letting them dry off for 5+ minutes with the battery compartment door open, then try turning the camera On again.

Has the new battery (if rechargeable) been charged up sufficiently? The replacement battery needs to be charged up for 6+ hours before its first use, owing to its having been on a shelf for a considerable time.

- Some questions:

How old is the camera? in months or years since you bought it.

Has the camera been dropped or otherwise subjected to mechanical shock(s) in its lifetime?
Has the camera been operated in or subjected to, temperatures below 32 degrees F (freezing point) or above about 100 degrees F ?
Has it ever been subjected to a humidity higher than 85 % or gotten wet ?

Has the camera been operated in a gritty or sandy environment, such as a beach, a seaside, a construction site, or the like?
Customer: replied 3 years ago.

the camera is two and half years and it No to all the other questions

Expert:  Russell H. replied 3 years ago.
OK. I am glad to hear that it has been treated well, but it has gotten out of warranty (-unless you bought an Extended Service Plan - one that has a term of more than 2 years that is - from Canon when you purchased it, perhaps.)

It does have a rather severe problem. But I must mention that 'ALS11111' does not match anything within my acquaintance, so perhaps clarification of that point - what error message it is showing - might help me with the advice I offer you.

Meanwhile, trying the suggestions I mentioned costs nothing and might help with whatever is wrong with the camera exactly.
Customer: replied 3 years ago.
I do believe it could be a battery problem. I have now ordered another one and will keep you up dated . If it does not work after replacement battery I shall have to return the camera to Canon for repair.

Thank you once again.
Expert:  Russell H. replied 3 years ago.
Once you have the new battery, you need to charge it up 6 hours in the charger before using it for the first time, owing to the polarization that develops during time sitting on a shelf in packaging.

If you need to send to Canon, you may start the process here:
http://usa.canon.com/cusa/consumer?pageKeyCode=onlineRepairLanding

Please rate my Answer - unless you would rather wait until the new battery has been tried - so that I may be paid for the work I have done on your question. Thanks, ***** ***** luck.
Customer: replied 3 years ago.
Russell

we have bought two new batteries did not appear to charge then we bought a new charger left the batteries on for 8 hours then the second overnight still the camera shows the batteries flat and the same thing happens 'switch on to whatever programme and the timer seems to be set for ten seconds it rattles through then two clicks and off we go again. Nothing! I have tried to download software but am not getting anywhere with that either (not too conversant with computers) I think maybe we had better take it to the camera repair shop but they are so expensive.
Expert:  Russell H. replied 3 years ago.
As unfortunate as it seems, it is confirmed that the camera needs either repair or replacement.

But, first try cleaning the terminals in the battery compartment, after removing the batteries, first by rubbing off with a fresh pencil eraser, then by wiping the terminals off with cotton swabs moistened in rubbing alcohol, then letting them dry off for 5+ minutes with the battery compartment door open, then try turning the camera On again.