How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Freddy M. Your Own Question
Freddy M.
Freddy M., IT Technician
Category: Digital Cameras
Satisfied Customers: 18398
Experience:  Years of experience.
15852642
Type Your Digital Cameras Question Here...
Freddy M. is online now

I have a canon legria HF20 camcorder. It has issues with power.

Customer Question

I have a canon legria HF20 camcorder. It has issues with power. When I connect with a lead to the mains it works (although this morning it was only intermittent until I connnected the mains lead to the shaving socket) but when I unplug it from the mains it immediately switches off. It seems to be fully powered as the screen show"9999" but as soon as I disconnect from the mains it goes off and if unconnected I can't get it to switch back on. Why is this and is it something I can fix myself or will I need an engineer (I did try a replacement battery but this seems to have made no difference)
Submitted: 2 years ago.
Category: Digital Cameras
Expert:  Freddy M. replied 2 years ago.
.
Hello my name is***** look forward to assisting and am very sorry to hear that you are having this problem. I want to warn you that it is possible you will need to replace a part in order to fix this. There are a few different things that can cause this and a couple different parts so we would need to troubleshoot to find out for sure. Have you tried a different battery yet?
.
Customer: replied 2 years ago.

Yes, I tried a different battery

Expert:  Freddy M. replied 2 years ago.
.
Ok have you tried a different charger? Even though it is providing power it may not be charging the battery.
.
Customer: replied 2 years ago.

Hi Freddy I could try a different charger but the screen shot shows 5 + hours of charge. However, when I unplug the camcorder from the power source it goes dead (I did notice a message momentarily on the screen saying "change battery" or something similar. The power then cut off and it's dead until I plug it into the mains again.

Expert:  Freddy M. replied 2 years ago.
.
When a charger fails it can look like it is charging when it is not. Please test a different one and let me know what happens. Leaving it charging for 20-30 minutes should be enough time to test. Please test with both batteries just to be sure and let me know the results when you can.
.
Customer: replied 2 years ago.

Hi Freddy I can't find anothe charger lead but here's some info that might be useful. When I disconnected it from the lead it said "47 mins" power. I carried it around for about 5 mins and it lost all that power and then said "change battery pack" and its now beeping and has now powered off.

Expert:  Freddy M. replied 2 years ago.
.
You said you already tried a different battery so we can rule that out, but what you just said would normally make me think the battery is dying. The only way we can rule out the charger is to test another. Some smaller electronics and camera shops will test it for you in hopes of selling you the new charger.
.
Customer: replied 2 years ago.

OK Thanks I'll try that. If it's not the charger what might it be

Expert:  Freddy M. replied 2 years ago.
.
If it is not the charger the next thing you would want to do is clean the battery contacts inside the camcorder.After that it normally indicates the board those contacts are integrated onto needs to be replaced. The most common reason however is the charger. If you have any questions at all click on reply to expert and let me know. If not please don’t forget to leave a positive rating for my help - it is greatly appreciated. Please note you are rating me only not this site or your camcorder.
.
Freddy M. and other Digital Cameras Specialists are ready to help you