How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Engineer
Category: Electronic Musical Instruments
Satisfied Customers: 17939
Experience:  Over 16 years of experience in the Electronics and IT industries.
30970729
Type Your Electronic Musical Instruments Question Here...
Pete is online now

My Clavinova CLP-820 is not powering

Customer Question

Hi. My Clavinova CLP-820 is not powering
Submitted: 1 year ago.
Category: Electronic Musical Instruments
Customer: replied 1 year ago.
The power cable is working without problems, in fact the internal power supply seems to be giving the required voltages (I measured it with an electronics professional).
There's a small led to the left of the piano (standing in front of it) that lights on whenever I press the power button, but the screen is off and there's no sound whenever I press any key.
The piano was working without problems, and then one day just didn't power on.
Expert:  Pete replied 1 year ago.
Hello,
Customer: replied 1 year ago.
Hi Pete, are you still there ?. Did you write anything other than just a Hello ?. I just see "Hello,"
Customer: replied 1 year ago.
Hi, I can see you're online but I don't see any answer ...
Expert:  Pete replied 1 year ago.
Sorry for the delay, I had just gone offline when you replied.Is it possible that the piano suffered any damage from a power outage or thunderstorm?Possibly an internal fuse has blown, or the switch is defective and is not turning on.Some further voltage testing will be required to see where exactly the power is not getting through to the main board and display.
Customer: replied 1 year ago.
Hi Pete
As I already mentioned before :
"...the internal power supply seems to be giving the required voltages (I measured it with an electronics professional).
There's a small led to the left of the piano (standing in front of it) that lights on whenever I press the power button, but the screen is off and there's no sound whenever I press any key."
Fuses are all working ok as well as the power switch.
Also, no power outage or thunderstorm occurred.
I just thought that the answer could be some know issue that I'm not aware of.
Very frustrating.
Any light on this other than the generic revision of power supply/fuses ?
Thanks
Expert:  Pete replied 1 year ago.
The power supply may be giving the correct voltages, but I suspect damage has somehow occurred on the main board or display.If there has been no power outage or thunderstorm then a part has likely failed, and further voltage testing will be required to determine which part.