How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Carl L Your Own Question
Carl L
Carl L, Technician
Category: Electronics
Satisfied Customers: 4058
Experience:  13+ Years of Computer and Electronics Experience. Current Company Owner as an IT Specialist in FL.
27991594
Type Your Electronics Question Here...
Carl L is online now

hi i have just opened my id1660 digital camcorder, i charged

Customer Question

hi i have just opened my id1660 digital camcorder, i charged it up, and turned it on, after displaying the polaroid logo, the screen just displays bands of green and white bands, with many bright and dark pixels?. this is a present for my daughter tomorrow so any help would be appreciated.
Submitted: 3 years ago.
Category: Electronics
Expert:  Carl L replied 3 years ago.
Merry Christmas and welcome to Just Answer, a Question and Answer Company. My name is Carl and I will be assisting you today.

Sounds like a loose LCD Cable or a faulty I/O Board that attaches to the LCD if you have color bands and / or lines. If you just opened this and it's new, I hate to say it but you need to exchange it but I doubt the store you bought it from will be open in time before you have Christmas.

If you can upload a picture, I can tell you with 100% certaintly but 95-99% of the time, color bands and / or lines is always a faulty LCD component.
Expert:  Carl L replied 3 years ago.
I'm just checking in to see if there is anything more that I can help you with.

I also ask that you select a Smiley Face above to show that I have helped you.

Thanks,
Carl L