How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Engineer
Category: Electronics
Satisfied Customers: 18296
Experience:  Over 16 years of experience in the Electronics and IT industries.
30970729
Type Your Electronics Question Here...
Pete is online now

Hi my mum has a Polaroid 20" TV TLU-02041B with built in Freeview

Customer Question

Hi my mum has a Polaroid 20" TV TLU-02041B with built in Freeview that has worked perfectly since 2007/8 until recent weeks when on two channels (ITV1 on channel 3 and Channel 4 on channel 4) the subtitles don't appear until you move to another channel, then back to the faulty channel, then switch TV off and on a few times.
This still happens with an attenuator between the aerial (external aerial) coax and the TV, and also if I plug an indoor aerial to the set. Picture quality is fine, subtitles appear on other channels with no difficulty - perhaps a little slow - but I can't remember if it has always been like that.
Submitted: 3 years ago.
Category: Electronics
Expert:  Pete replied 3 years ago.
Hi there,

When subtitles are missing or not showing correctly, this is usually resolved by a retune - the problem is usually caused when the channels have moved to different multiplexes but the TV has not been retuned accordingly.

Hope that helps,

Pete.