How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eng. Andres Your Own Question
Eng. Andres
Eng. Andres, Engineer
Category: Electronics
Satisfied Customers: 68
Experience:  Electronic Eng. Electronics Specialist. Circuit designer
54002000
Type Your Electronics Question Here...
Eng. Andres is online now

-My Siemens Gigaset C475 has stopped working after a

Customer Question

Hello -My Siemens Gigaset C475 has stopped working after a power cut. It just has a >>>> symbol, a partially filled battery symbol and flashes 'Base 1'. There is no red light on the base unit and no dial tone. What can I do please? Thanks Tony
Submitted: 2 years ago.
Category: Electronics
Expert:  Richard replied 2 years ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, click on Reply to Expert to reply to me, a rating is only needed when we are finished.
When you put the batteries back in, did this happen straight away or took some time?
Customer: replied 2 years ago.

Hi Richard - I have now managed to fix the phone myself. I thought I would get a MyAnswer expert instantly last night but as it took nearly 20 hours to get a response, I could not wait that long. No criticism of you personally -thanks for responding -but how do I get my £20 back as I never used your service??

Thanks, Tony

Expert:  Richard replied 2 years ago.
No problem at all Tony
You get your refund here
http://ww2.justanswer.com/help/how-can-i-request-refund
Mind telling me what you did to fix it?
Thanks
Richard
Customer: replied 2 years ago.

I found a phone no. for the Gigaset Helpline. They told me the issue was that there was no power getting to the base station and got me check all the connections. When i pressed them all in hard, the red light on the base unit came on and everything re-set itself. Really silly but glad it was so simple in the end.

Ive applied for a refund. Thanks, Tony

Expert:  Richard replied 2 years ago.
thanks Tony