How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 37650
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

I have a Panasonic Lumix FZ45 digital camera which I use frequently.

Resolved Question:

I have a Panasonic Lumix FZ45 digital camera which I use frequently. Now the pop-up flash does not function at all. I've checked that it is set to Auto and the Burst mode is off. Still doesn't work. Is there anything I can do myself to get it working again?
Thanks for your help!
Submitted: 2 years ago.
Category: Electronics
Expert:  Richard replied 2 years ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, click on Reply to Expert to reply to me, a rating is only needed when we are finished.
As the first step, remove the battery and wait 10 minutes to let the power drain from the chipset.
Then put the battery back in, turn on the camera and tell me if the flash now functions.
Let me know the results please
Customer: replied 2 years ago.

Hi Richie, many thanks for your prompt reply! I did as you suggested and the flash still is not working. I also tried the Forced Flash setting - still no flash. Is there anything else I can try?

Expert:  Richard replied 2 years ago.
Thanks Reg
Yes, I want to reset the camera back to factory settings.
On the camera
Press Menu/Set
Tab down to the "toolbox icon" (3rd down after camera, then movie, then toolbox)
Tab down until you reach page 5 of this menu area and the first one at the top of this page is "RESET" and this will set you back to the factor settings.
then try the flash
Let me know the results please
Customer: replied 2 years ago.

Tried the reset, and also switched it on and off - still no flash.

Expert:  Richard replied 2 years ago.
Thanks Reg, it confirms the problem
It is the internal mainbaord that has faulted and will be the chipset that controls this function.
A corrupted firmware can cause this. But we have ruled this out by trying to reinstall it.
I am really sorry about this and you are going to have to return the camera to have it replaced. It will be covered by the warranty if this has not expired, and the replacement will be done at no cost to you.
I am really sorry about this, and if you have problems, or would like any additional information or assistance, please do not hesitate to let me know.
And if you can take a second to rate my service, that would be greatly appreciated.
Thank you
Customer: replied 2 years ago.

It's OK, it's not your fault. You have confirmed the need for me to get it repaired by an expert. I bought it just less than 4 years ago, so it's out of warranty. Thanks for your excellent advice!

Expert:  Richard replied 2 years ago.
your most welcome Reg, just get a quote before going forward with the repair as it may be cheaper to purchase a replacement then get it fixed (as then you get a new warranty).
If you need anything else, please let me know and please remember to rate my service.
Thank you
Richard
Richard and other Electronics Specialists are ready to help you