How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 38375
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

Can anyone answer a question related to the service menu on

Customer Question

Can anyone answer a question related to the service menu on a Samsung TV?
Submitted: 2 years ago.
Category: Electronics
Expert:  Richard replied 2 years ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, click on Reply to Expert to reply to me, a rating is only needed when we are finished.
Can you tell em what you wish to ask about it please?
Thank you
Customer: replied 2 years ago.

I have a Samsung EH5000 TV which has suddenly developed a strange problem with its 2 HDMI ports. I have three devices which when connected to the TV it reports no signal on the HDMI port. These three are: a Virginmedia non-recordable TIVO box, a laptop connected by HDMI and a Google chromecast. However, there are two devices which work fine via HDMI: these are an Amazon Firestick and an Apple TV. This clearly signals that the HDMI ports are not completely broken because they work fine with these devices. My research online indicates this could be a handshake problem and what I hope is that it could be remedied by making changes within possibly within the service menu of the Samsung TV. I have found 15 settings related to HDMI in there. Hope you can help.

Expert:  Richard replied 2 years ago.
Ok, so this constructions was working before and just stopped working correct?
Customer: replied 2 years ago.

Yes, these are not new devices. Everything was working perfectly and then all of a sudden it went as described above.

Expert:  Richard replied 2 years ago.
ok, it is not the settings, as these do not change themsselves, so do not mess with these please they are correct else it would not have worked.
First thing to do to clear residue power is to remove the power to the TV and wait 10 minutes. While waiting, hold the power button for 60 seconds then release.
Connect the power and tell me if it now functions correctly please.
Customer: replied 2 years ago.

I have only looked at the settings withouth changing anything. I've already tried the solution you suggested because it was one of the first things I read about online as an answer to the problem. In fact, I've tried it several times in the way you described with the 10-minute method. It didn't work.

Expert:  Richard replied 2 years ago.
Ok, have you factory resetted the TV?
Can you go to the standard menu on the TV and reset the TV, so you run the setup again.
Let this complete and when it has and the TV is setup, then test if it now functions please.
Customer: replied 2 years ago.

Yes I've done several factory resets already. I've tried every obvious thing already.

Expert:  Richard replied 2 years ago.
ok, you did not mention anything about what you have already tried, so please mention what you have done already so I do not go over this again.
Customer: replied 2 years ago.

1) Factory resetting

2) TV off for ten minutes + power

3) Swapping HDMI cables over

4) Trying different ports

5) Testing devices on another TV to make sure they aren't faulty (they aren't)

This is what I've done so far

Expert:  Richard replied 2 years ago.
ok, in the service menu
What settings are hotplug and hotplugctr set to?
Customer: replied 2 years ago.

HDMI Hot plug > Disable

But I dont' see the second option you mentioned. I do see HOTPLUG SWITCHING. Is that the same thing>

Expert:  Richard replied 2 years ago.
yes, but they can seperate it at times, but it should be disabled.Can you list the rest of the HDMI settings you have listed please.
Customer: replied 2 years ago.

DVI/HDMI sound: Auto

HDMI HOT PLUG: Disable

HOT PLUG SWITCHING: Boot

HOT PLUG DURATION: 1200ms

CLK TERM DURATION: 12000ms

HDMI FLT CNT SIG: 100ms

HDMI FLT CNT LOS: 100ms

UNSTABLE BAN CNT: 500ms

HDMI ERR CNT: 0

HDMI ROBIN: ON

HDMI CALLBACK: OFF

HDMI CTS THLD: 8

HDMI CTS CNT1: 0

HDMI EQ: AUTO

HDMI WRITE TYPE: Combine

HDMI Switch: None

Expert:  Richard replied 2 years ago.
Everything is ok, but to be sure
Change HOT PLUG SWITCHING: Boot to Enabled or what text your version has that relates.
Restart the TV and then test
let me know the results please.
Customer: replied 2 years ago.

Sorry that didn't help. The other option in switching was called Source.

Expert:  Richard replied 2 years ago.
ok, under HDMI Switch, which options do you have for your firmware?
Customer: replied 2 years ago.

The options are SIL 9287 and TMDS461

Expert:  Richard replied 2 years ago.
ok, leave it as it has not impact on this.The only cause left for this is a hardware issue with the mainboard that the ports are soldered to.There is no software cause left for this as we have ruled it out. It will be related to the power needed by the devices and why some do and others do not work. I am really sorry about this and you are going to have to return the TV to have a diagnostics run and the board replaced. It will be covered by the warranty if this has not expired, and the replacement will be done at no cost to you.I am really sorry about this, and if you have problems, or would like any additional information or assistance, please do not hesitate to let me know.And if you can take a second to rate my service, that would be greatly appreciated.Thank you
Customer: replied 2 years ago.

Some additional information for you.

If I turn on two of the devices that don't work (Google chromecast and Virginmedia box) the boot-up messages of those devices does appear on the screen through HDMI. Once that phase is finished the HDMI shows no signal. Does that mean anything to you or change anything about your previous answer?

Expert:  Richard replied 2 years ago.
Only confirms it, the port is shorting out and loses the signal.It could be the device but it is ruled that out because multiple devices have this issue.
Customer: replied 2 years ago.

Is there any possibility that a HDMI booster could rectify the situation?

Expert:  Richard replied 2 years ago.
no sorry, as you did not need one before, its not the cause of the issue, its the port itself faulting.
Customer: replied 2 years ago.

I totally understand that your diagnosis could be the right one and that if I pursue this I might be wasting my time.

Nevertheless, I just want to exhaust every possibility. Within the Samsung service menu there is an option marked Expert that is grayed out. Do you know what's in that menu and is it possible to access it? I have learned how to use Factory and 3XSpeed to access the extended menu but that doesn't open Expert. Any ideas on that?

Expert:  Richard replied 2 years ago.
its no problem.
Its for use in the factory when there is a direct connect to the chipset, you wont be able to access it.
But it has nothing to do with this. Remember, nothing was changed here, so nothing here is stopping it from working.
Richard and 2 other Electronics Specialists are ready to help you
Customer: replied 2 years ago.

Ah ok that's clear.

One more thing sorry. The devices that were working have stopped working and this is a shame because I have a Virginmedia engineer coming today to check things. If I can't show him that some devices work he'll just think it's all completely broken and there's nothing to do. Could that have been related to any of the changes we made yesterday in the service menu?

Expert:  Richard replied 2 years ago.
We only made one change, so set HDMI HOT PLUG: To Disable and nothing has changed
But nothing about this is related to the one change we did yesterday, especially if you change it back
Expert:  Richard replied 2 years ago.
If you would like any additional information or assistance, please do not hesitate to let me know.
Else if you can take a second to rate my service by clicking one of the stars at the top of the screen then submit, that would be greatly appreciated.
Thank you