How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 37649
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

I have a new Panasonic TV. It is set up with an external yamaha

Resolved Question:

I have a new Panasonic TV. It is set up with an external yamaha amp and stereo speakers. The two are connected by an optical audio cable. I also have a Humax box (HDMI to TV) and an Apple TV, (HDMI to TV), and a Sony Blu ray player (HDMI to TV) and a networked music server (old macbook connected via ethernet to the TV). Essentially all audio signals go into the TV either via ethernet or hdmi. The audio signal of whatever is playing is then routed to the amps and onwards to speakers. Everything has been working fine for a month until last night when the Netflix app on the Viera lost sound thru the amp. It could still be played via the TV speakers. Other Viera apps such as BBC Iplayer worked. All other inputs worked. I have tried platying with a couple of the sound settings on the Viera but to no avail. Any suggestions welcome
Submitted: 1 year ago.
Category: Electronics
Expert:  Richard replied 1 year ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, a rating is only needed when we are finished.
Have you factory reset the TV in order to reload the netflix app?
I saw Factory reset, but was not sure which one you did.
Customer: replied 1 year ago.
yes
Customer: replied 1 year ago.
sorry to be clear i did the factory reset on the tv
Expert:  Richard replied 1 year ago.
ok, play a movie and within the Audio & Subtitles menu during playback select audio 5.1
Does it then play the sound correctly?
Customer: replied 1 year ago.
sorry play a movie through what device - netflix on the Panasonic, on the blu ray player, or via apple tv?
Expert:  Richard replied 1 year ago.
its the netflix app you have the issue correct?
Customer: replied 1 year ago.
correct
Expert:  Richard replied 1 year ago.
yes, so via this please.
and within the Audio & Subtitles menu during playback select audio 5.1
Does it then play the sound correctly?
Customer: replied 1 year ago.
through the tv yes, through the stereo amp no (no sound at all)
Expert:  Richard replied 1 year ago.
you selected the Audio 5.1? ion the Netflix app?
Customer: replied 1 year ago.
hello? any update
Expert:  Richard replied 1 year ago.
I sent you a message, I think you missed it...
you selected the Audio 5.1? ion the Netflix app?
Customer: replied 1 year ago.
yes i missed it. and Yes I did select Audio 5:1 in the Netflix app.
Expert:  Richard replied 1 year ago.
ok, sounds like your Amp does not support DD+
On your TV, do you have a Digital Audio Out connection like this?
http://techguyla.files.wordpress.com/2014/02/img_0244.jpg?w=198&h=243
Customer: replied 1 year ago.
Yes, except that it is oriented vertically - i.e you stick the connection in from underneath but the basic shape of the connection is identical. And clearly it is working since my music server, and apple tv, plus regular tv and BBC iplayer all play successfully out through it.
Expert:  Richard replied 1 year ago.
yes, but the netflix app has updated and its likely it broke the compatibility with your TV to output to the amp.
Do you have this connection connected to your Amp?
Customer: replied 1 year ago.
Yes the optical out goes straight from the TV to the amp
Expert:  Richard replied 1 year ago.
Is the TV set to always send audio out via the port? If your not sure, tell me the model of the TV
Customer: replied 1 year ago.
checking
Customer: replied 1 year ago.
Its a panasonic Viera 50AS650 Series
Expert:  Richard replied 1 year ago.
ok, play netflix and keep pressing the button on the remote to the right of menu.
Do you get any sound via the amp when cycling via all options?
Customer: replied 1 year ago.
ok that is the text button on my remote, correct?
Customer: replied 1 year ago.
no options appear
Customer: replied 1 year ago.
ok that ftp link doesn't work for me - let me see if I can get it from elsewhere
Expert:  Richard replied 1 year ago.
Customer: replied 1 year ago.
Thanks, ***** ***** Unfortunately the remote displayed on page 15 is not the remote that shipped with my TV. I do not have a surround button, nor is there any similar button on my remote.
Customer: replied 1 year ago.
I have - to the right of menu in order, TEXT; STTL, ASPECT
Expert:  Richard replied 1 year ago.
strange and may explain why it does not work correctly with the latest release of the Netflix App.
If you go to Settings, Audio, is there and option there to always send audio out via the Optical cable?
Customer: replied 1 year ago.
No there are numerous options within the SOUND (not Audio) sub-menu. Possible relevant ones are:
Surround: (Options Off or Virtual surround)
Speaker setting: (Options TV Speaker , Headphone, Off)
SPDIF selection (Options, Auto or PCM)
Expert:  Richard replied 1 year ago.
Ok, set Surround to Virtual
And test SPDIF on Auto or PCM
Tell me if it gives you sound on any of these please.
Customer: replied 1 year ago.
OK setting Surround to Virtual has induced a mid frequency chattering through the amp ( which I am struggling to get rid of)
This before I canged the SPDIF setting (which makes no difference)
Expert:  Richard replied 1 year ago.
does the chatter sound anything related to netflix?
Customer: replied 1 year ago.
no
just a electronic chatter and continous
Expert:  Richard replied 1 year ago.
ok, then switch it back to how it was.
Can you connect composite cables to the composite audio out ports (the white and red) on the TV to the input on the Amp. Make sure the Amp is set to this input and then try Netflix.
Does it then run?
Customer: replied 1 year ago.
no chatter on regualr tv replay or BBC iplayer
Re the alernate cabling, give me a monet I need to see what cables I have available in the cupboard
Expert:  Richard replied 1 year ago.
thanks
Customer: replied 1 year ago.
did as suggested still no signal to the amp
Expert:  Richard replied 1 year ago.
are you sure the audio is coming out of the ports? Disconnect the Digital connection and everything else to the Amp and tell me if it still gets a sound.
Customer: replied 1 year ago.
no sound via amp via the new cabling set up
Expert:  Richard replied 1 year ago.
Are you sure you set the input correctly on the Amp to the composite input ports?
Customer: replied 1 year ago.
there is only one regular left/right red/white audio out on the TV which I am using. There are multiple red/white input slots on the amp. I selected the one maked tuner and then set the control to replay through the tuner - but have no sound. Have tried alternate cables as well.
Expert:  Richard replied 1 year ago.
you tried playing normal TV to see?
Customer: replied 1 year ago.
Yes
Customer: replied 1 year ago.
I think we are going to have to abandon this unless you have a better suggestion. The amp is working fine via the optical connection for all inputs except viera app Netflix. Ill just have to listen to that via the TV
Expert:  Richard replied 1 year ago.
ok, then we are out of options, not sure why the composite cables are not working unless there is an issue with the composite ports on the TV, but we have done a reset and tried all connection methods.
And update in Netflix has render it incompatible with the TV
Apart from waiting for a future update you would need to consider using a Chromecast adapter to play Netflix which will work for you.
http://www.google.com/chromecast/tv/
Richard and other Electronics Specialists are ready to help you
Customer: replied 1 year ago.
thanks for your help