How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 37544
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

I have an Olympus E-520 digital slr. When I turn on the

Customer Question

Hi I have an Olympus E-520 digital slr. When I turn on the camera without a memory card inserted the camera displays card error, this shouldn't be the case. Any ideas
Submitted: 1 year ago.
Category: Electronics
Expert:  Richard replied 1 year ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, a rating is only needed when we are finished.
When you put a card into the camera, does it still give the card error or it actually can access the card and functions as normal?
Customer: replied 1 year ago.
No when a card is inserted you don't get the card error. I'm a retailer of used cameras with a lot of experience with Olympus digital slrs. When turning an Olympus digital slr without a card present you should just get a zero for shots remaining, not a card error message thanks
Expert:  Richard replied 1 year ago.
with this model you should get a no card message as there is no internal memory.
What steps did you take to do the factory reset?
And did it complete this?
Customer: replied 1 year ago.
1. Select P on the mode dial.
2. Open the card door and turn on the camera.
3. Hold down the Menu and the OK buttons at the same time for 5 seconds.
4. Olympus E-520 is displayed.5. Release and again hold down the Menu and the OK buttons at the same time for another 5 seconds.
6. Reset has been done is displayed
7. Press the OK button.
8. Shut the camera off
Expert:  Richard replied 1 year ago.
Thanks
Can you also do it via the menu please.
Page 30 of the manual here will show you how
http://www.olympus.co.jp/en/support/imsg/digicamera/download/manual/esystem/man_e520_e.pdf
Once done it should give No Card as the message.
Let me know the results please
Customer: replied 1 year ago.
Tried that no change still same card error
Expert:  Richard replied 1 year ago.
ok, the firmware is malfunctioning and its reading off the incorrect message when it detects no card. This can signify a memory issue.
If you put a working card in, then take a few pictures.
Then power it off, power it on.
Does it give the same message?
Customer: replied 1 year ago.
Tried that still no change
Expert:  Richard replied 1 year ago.
Its an issue with the firmware, and likely to be a memory issue (its reading the wrong message when handling the action when it detects no card).
As it is working correctly, I would leave it as you cannot really use the camera without a memory card anyway, else you would need to send it into olympus and have them replace the mainboard in the camera that the memory resides on.
Customer: replied 1 year ago.
OK thanks
Expert:  Richard replied 1 year ago.
your welcome
If you would like any additional information or assistance, please do not hesitate to let me know.
And if you can take a second to rate my service by clicking one of the stars at the top of the screen then submit, that would be greatly appreciated.
Thank you