How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Josh Your Own Question
Josh
Josh, Computer Enthusiast
Category: Electronics
Satisfied Customers: 20221
Experience:  Expert for over 10 years
50836188
Type Your Electronics Question Here...
Josh is online now

I have an Ectaco Partner Lux translator which is about 3

Customer Question

I have an Ectaco Partner Lux translator which is about 3 years old. One of its facilities is to connect by Wi-Fi to Google Translate and that worked well until recently. But now when I type in a word or sentence for translation it only gives the message "translation error". It makes no difference which language I want to translate from or translate into - the error message is always the same.
It does not seem to be a connection problem. The Wi-Fi icon still appears, showing a reasonable signal strength, and the familiar Google Translate screen appears and accepts inputs in any of its usual range of languages. It just will not translate anything.
Can you please explain what has gone wrong, and what I should do to restore that facility?
Jack
***@***********
29 March 2016
Submitted: 1 year ago.
Category: Electronics
Expert:  Josh replied 1 year ago.
Hi, Go to the Main Menu.Open the Launcher Menu.Tap Restart system on the Launcher Menu.In the Ready for Restart screen, tap Restart now