How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Engineer
Category: Electronics
Satisfied Customers: 38559
Experience:  Electronics Engineer
32989067
Type Your Electronics Question Here...
Richard is online now

Our Panasonic TX-42AS650B is having trouble loading the BBC

Resolved Question:

Our Panasonic TX-42AS650B is having trouble loading the BBC i-player app. It always used to work but no it just buffers all the time.
We have a BT HUB 5
Submitted: 1 year ago.
Category: Electronics
Expert:  Richard replied 1 year ago.

Thank you for your question, my name is ***** ***** I look forward to assisting you.

Please note, a rating is only needed when we are finished.

Can you please remove the power to the TV (so unplug it from the power socket).

Then on the actual TV, hold the power button for 60 seconds then release.

Then wait 10 minutes, connect the power again to the TV, turn it on and tell me please if it is now operating correctly.

Let me know the results please

Customer: replied 1 year ago.
I have tried what you suggested and the app does load ok, but as soon as you choose a TV programme it goes back to the i-player main menu and a message comes up "Something went wrong playing this programme"
Expert:  Richard replied 1 year ago.

Thanks

Can you locate the reset button on the BT hub and hold it in for 10 seconds then release.

Then power off the TV, wait 5 minutes, power it on and tell me if iPlayer now works please

Customer: replied 1 year ago.
I have done that. It takes a while to load and then when it displays the main i-player menu (Home Channel etc) it comes up with an error message "Something went wrong displaying this content"
Expert:  Richard replied 1 year ago.

ok, we will need to do a full reset of the TV, this will wipe all data and return it to new so you will need to set it up again like when you first received it

To do this, go to the System Menu, Setup Menu, then choose Shipping Conditions to return it to new. Then set it up again and tell me how it now functions please.

Richard and other Electronics Specialists are ready to help you
Customer: replied 1 year ago.
Hi Richard,That seems to have done the trick.
Many thanks - can give you a good rating now no problem