How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sean Your Own Question
sean
sean, Ford Technician
Category: Ford
Satisfied Customers: 3105
Experience:  Ford Master Technician.
31670004
Type Your Ford Question Here...
sean is online now

Hello I drive a ford focus zetec tdci 1.6 05 plate And

Customer Question

Hello
I drive a ford focus zetec tdci 1.6 05 plate
And driving home from camp it's quite a long drive
Got back in to plymouth to find the red circle with an exclamation mark in the middle was permently and then my indicator works on the outside but the lights on dashboard not coming on
Any ideas what's going on ?
Many thanks
Submitted: 4 years ago.
Category: Ford
Expert:  sean replied 4 years ago.

Hello, I hope I can offer you some assistance.

When the warning light came on did the engine lose power? Did any other electrical concerns show apart from the indicators?

Let me know and I'll reply as soon as I'm able to.

Thank you.

Customer: replied 4 years ago.
It didn't really lose any power that I was aware but I didn't drive it much further after it came on another weird thing was the light the inside light was permently on and wouldn't turn off unless I used the switch I checked to make sure all the doors were closed properly aswel
Expert:  sean replied 4 years ago.

Hello again,

if the car didn't lose power then the PCL will have come on due to an electrical concern rather than an engine management concern, the indicator and interior light concern would confirm this.

To start with I would check the fuse box inside the car on the passenger side. Make sure you have your radio code, disconnect and inspect the electrical connectors to the fuse box, this fuse box is also a control module called a GEM, this controls many electrical systems on the car. Make sure there isn't any sign of corrosion on any of the terminal pins in either the connectors or the pins in the fuse box especially the connectors on top of the fuse box.

If there is any corrosion then the fuse box will need replacing, a new fuse box will need to be programmed to the car, as I mentioned earlier it's also a control module.

If there is signs of corrosion then the cause is water ingress so the source of this will need to be found and repaired.

Start with checking as above, let me know if I can assist further and I'll reply as soon as I can.

Best wishes,

Sean.