How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3286
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

my ford focus will not drop to idle speed have put a new idle

Customer Question

my ford focus will not drop to idle speed have put a new idle control valve on a new mass air flow checked all pipe for cracks but still sits at about 2500 rpm then drops to about 1500 rpm but its to high can anyone help cheers willie
Submitted: 3 years ago.
Category: Ford
Expert:  Gallagher99 replied 3 years ago.
Hi there Willie good afternoon to you


Ok what engine is fitted to your vehicle ie1.8 zetec

Regards Brian
Customer: replied 3 years ago.

hi brian its a 1.6 mate

Expert:  Gallagher99 replied 3 years ago.
Hi there , thanks


Ok if all the breather hoses are intact at the inlet manifold (no collapsed or leaking hoses causing excess air to be drawn in )
then the most common cause is a faulty throttle position sensor (located on the side of throttle body housing )

This can cause s few different issues (high idle / revs going up when clutch depressed etc )

If you are happy with the breather pipe work at the inlet manifold then the TPS is the most likely cause




If you need anymore help or advice on this issue willie please let me know 
If you are completley satisfied with my answer /advice 
PLEASE RATE MY ANSWER 
Kind regards XXXXX XXXXX and have a nice day


Brian 
Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 3 years ago.


hi mate i have order a new tps will let you know how I get on thanks for your help

Customer: replied 3 years ago.


hi Brian its Willie i have put a new tps on and new pipes but still have the problem.