How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3247
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

2002 transit t280. all of a sudden when changing gear the engine

Customer Question

2002 transit t280. all of a sudden when changing gear the engine started revving highly with no response from throttle. had to turn off ignition. Tried to restart but engine revs started to climb of their own accord.
Submitted: 2 years ago.
Category: Ford
Expert:  Gallagher99 replied 2 years ago.
Hi there ,good evening to you
Ok the most common cause of this issue is a faulty accelerator pedal this is a fully electronic throttle pedal (flyby wire)
There is 3 potentiometers inside the pedal (resistance tracks )
Over time the surface of the resistance tracks become pitted/cracked causing incorrect information to be sent to the pcm this causing the revs to raise on there own
Ideally with the fault present the signals can be watched on a live datalogger (this lets the technician visually see the signals being sent out from the pedal
If you need anymore help or advice on this issue please let me know
If you are completley satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice evening
Brian
Customer: replied 2 years ago.

Thank you. So should I just fit a new accelerator pedal and plug in sensor again.

Expert:  Gallagher99 replied 2 years ago.
Hi there yes
This will be your root cause and a common issue on the older transits
Refards Brian
Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 2 years ago.

Hi, have got new accelerator pedal and plugged in sensor, started engine and same thing happened. The engine revs started building up again of their own accord. I switched off the engine and started it up again with the accelerator pedal unplugged and the engine started over revving again???

Customer: replied 2 years ago.

got your reply this morning but cant see an answer to my problem?

regards, ***** *****

Expert:  Gallagher99 replied 2 years ago.
Hi there Ivor good afternoon to you
Sorry for the delay
What rpm is the engine going up to itself
Also do the revs stay high and take a while to come back down
Regards Brian
Customer: replied 2 years ago.


Hi Brian, the revs build up to about 5000 rpm and stay there. I turn the engine off to prevent damaging the engine. Should I let it continue revving to see if it comes down on its own?


 


Regards, Ivor

Customer: replied 2 years ago.


Hi, still awaiting response to my last comments. Thanks. Ivor

Customer: replied 2 years ago.
Relist: Other.
Still awaiting a response from 20th October?