How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3207
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

C- max 58 registration. My heated windscreen does not work.

Resolved Question:

C- max 58 registration.
My heated windscreen does not work. The heated washer jets are broken, but 12v seems to get to them. Is there a link between the two ? My Ford booklet tells me they should both come on when you press the switch beside the radio. This switch works and lights the led. What could be the fault ?
Submitted: 2 years ago.
Category: Ford
Expert:  Gallagher99 replied 2 years ago.
Hi there good afternoon to you
Ok so you still require assistance with this issue
When you say the heated jets are broken is the wiring broken
Regards Brian
Customer: replied 2 years ago.

No. wiring to jets are ok. 12v shows at the connection, but this comes on with ignition switch, not with heated windscreen switch. My Ford booklet ( user guide) says they should come on with heated windscreen.

Surely this 12v should not come on and heat the washers in the height of summer !!

Expert:  Gallagher99 replied 2 years ago.
Hi there sorry for the delay
Ok the heated front washer jets and heated front windscreen aren't linked together
The heated washer jets are fed a constant 12 volts through fuse 136(15amp ) in the passengers fuse box with the ignition on/engine running
The heated windscreen. Is fed through fuses 14&16 in the engine bay fuse box (switch activated you should have 12 volts across these fuses )
Fuse 14 feeds the right side and fuse 16 feeds the left side
The windscreen has 2 bi-metalic strips with 1 pin multiplugs in the end of them at each side (these can be accessed by popping up the scuttle panel and testing for voltage
The ground for the heated eindscreen is in the interior light area
If the feeds and earth are ok at the windscreen then the windscreen will be the issue
If you need anymore help or advice on this issue please let me know
If you are completley satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice evening and merry Christmas
Brian
Customer: replied 2 years ago.

So is the heated washers on whenever car is running irrespective of weather ? Isn't this wasteful of energy ?

Where is the device which turns off windscreen heater after a certain amount of time ?

Could this be at fault ?

Expert:  Gallagher99 replied 2 years ago.
Hi there good morning to you
Yes the heated keys are on constantly (no switch or relay ) with ignition switched on or engine running
I always thought they were operated with the heated rear screens like the heated mirrors but this is not the case
The heated front screen relay is earthed by the GEM module (fuse box in passengers footwell ) thus sending a feed through the fuses 14&16 in the engine bay fuse box and onto the windscreen
If you have voltage at these fuses with screen switch on then the GEM module is operating correctly
If you need anymore help or advice on this issue please let me know
If you are completley satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day and merry Christmas
Brian
Customer: replied 2 years ago.

Many thanks for all this info. You have helped me solve the windscreen problem!

You mentioned the common earth at the top. As both halves of the windscreen had failed I thought it was more likely to be this common earth behind the interior light. Sure enough I cleaned the contact and screwed it tighter and now it seems to be back in working order!!!

The heated washers, I am still not certain about as it is difficult to tell at the moment if they are working or not. They have 12v connected to them and my meter shows they have some resistance between the contacts when disconnected. So I think my local Ford garage is wrong...I think they are working. I have little faith in their knowledge/skills. From what you say about them working whenever the ignition is on, it looks like I cannot trust the Ford handbook either !

Thanks ! Excellent service !

Expert:  Gallagher99 replied 2 years ago.
Hi there good evening to you
no worries Iam glad advice helped you resolve this issue
If you ever need any future technical help or advice with you vehicle please let me know
If you have been completley satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice evening and merry Christmas
Any positive feedback or bonunes are greatly appreciated
Brian
Gallagher99 and other Ford Specialists are ready to help you

Related Ford Questions