How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3245
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

My Ford Scorpio Cosworth 24v 2.9 litre has been in storage

Customer Question

my Ford Scorpio Cosworth 24v 2.9 litre has been in storage for 12 months being restored.Now the ABS light comes on , is there a quick fix or is it an expensive exercise
Submitted: 2 years ago.
Category: Ford
Expert:  Gallagher99 replied 2 years ago.
Hi there ,good afternoon to you
Ok yes an illuminated ABS light is an MOT failure
In my experience of these vehicles I would suspect corrosion in one of the abs sensor multiplugs
If you remove each and sensor multiplug and inspect for blue /green corrosion on the connections this causes the and light to be illuminated
Ideally you should have a fault code check done on the ABS module to verify what fault code is logged in the module this makes diagnosing the issue a bit easier as it directs you to which part of the system is the issue
Is: left front sensor circuit
But in my experience these are prone for corrosion in the abs multiplugs
If you need anymore help or advice on this issue please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day
Brian
Customer: replied 2 years ago.

Hi Brian ,is it easy to check the multiplugs ? how much to replace approx

thanks Graham

Expert:  Gallagher99 replied 2 years ago.
Hi Graham good evening to you
Ok if you go to each abs sensor (fitted at each wheel hub ) and dissconnect the multiplug from each sensor in turn checking for corrosion
In most cases if slight corrosion is found them you can just clean the plug out with wd40
If no corrosion is going graham you should have a quick diagnostic fault code check done on the and module to clarify which fault code is causing the light to illuminate this can save a lot of time and money as if there is nothing visually obvious a fault code is imperatives for correct diagnosis of the issue
If you need anymore help or advice on this issue Graham please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice evening
Brian
Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 2 years ago.

Hi Brian

are replacment sensors expensive ? thanks

Expert:  Gallagher99 replied 2 years ago.
Hi there ,good evening to you and sorry for the delay
Ok I would advise buying non ford sensors if issue is found as they do the exact same job for a fraction of the price
Kind regards ***** ***** and have a nice evening
Brian