How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Gallagher99 Your Own Question

Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3017
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

2003 Fiesta 1.4TDi recent intermittent loss of speedo and/or

Customer Question

2003 Fiesta 1.4TDi recent intermittent loss of speedo and/or trip meter. Yesterday drove it home and left it for 5 minutes .Tried to start it and no power to the point where radio asked for the code ,now clicks when I try and start it but checked battery and it is fully charged ,tried jump start anyway with just clicking and all displays go out .
Submitted: 1 year ago.
Category: Ford
Expert:  Gallagher99 replied 1 year ago.
Hi there ,good morning to you
Ok did the battery light come on with the abs light (howsy times recent to the non start has this happened
Regards ***** *****
Brian
Customer: replied 1 year ago.

All lights came on including battery but all go off when I try to start it

Expert:  Gallagher99 replied 1 year ago.
Hi there thanks
Ok you speedo and trip issue (------) on dash is most commonly down to a communication issue with the Abs Module
The non start concern you have is down to the battery either not taking a charge (not being charged) or most commonly not holding a charge
The fact you switched the car off and a few minutes later it was clicking tells us that the battery is the issue
What to do is connect jump leads if you can and leave them connected to a running vehicle for 10-15 minutes to bring the voltage up
As the surface voltage may be ok ie: charger shows its ok but under load (when you attempt to crank the engine the voltage will drop to around 6 volts etc
Thus you get your click noise
From your description I would be replacing the battery and checking the charging rate once the vehicle is started which should be around 14.3 volts
If you need anymore help or advice on this issue please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day
Brian
Customer: replied 1 year ago.

Trying a jump start didn't work despite waiting for 5-10 minutes and the battery charger showed fully charged so not confident that battery is problem will have to remove it and get it tested before I am confident of your diagnosis

Expert:  Gallagher99 replied 1 year ago.
Hi there
No worries
Have you monitored the voltage using a multimeter to see reading on crank as these diesels require a minimum of 10.6 volts to crank over
Regards Brian
Customer: replied 1 year ago.

Battery reads 12.6v at rest

Expert:  Gallagher99 replied 1 year ago.
Hi
What is it reading on crank (when click is heard ) as the 12.6 may just be surface voltage or false voltage as it's known
Regards Brian
Customer: replied 1 year ago.

Haven't tried that yet will try later and respond as I am out at the moment

Expert:  Gallagher99 replied 1 year ago.
Hi there
No worries there's no rush I will receive email notification of your reply
I would just like to rule this out as a methodical part of our diagnosis
Regards ***** *****
Brian
Customer: replied 1 year ago.

Hi ,after leaving it all day ,central locking didn't work, no lights on dash initially ,although fuel gauge and temp gauge came up after turning key several times .Battery read 12.4v but when key turned it dropped to 6v and slowly came back up to 12v when I removed the key .Dropped to 6v before reaching the point where the starter should have engaged

Expert:  Gallagher99 replied 1 year ago.
Hi there good evening to you
Ok this tells us the battery is the issue as the the voltage drops to 6 volts on crank (the 12 volts you see is false voltage ) or surface voltage
This means the battery has an internal cell issue and needs to be replaced
If you need anymore help or advice on this issue please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day
Brian
Customer: replied 1 year ago.

Hi I will get a new battery tomorrow and let you know how it goes cheers

Expert:  Gallagher99 replied 1 year ago.
Hi there no worries I look forward to your reply
Kind regards ***** ***** and have a nice evening
Brian
Customer: replied 1 year ago.

Hi will reply when I have received and fitted new battery ,cheers

Expert:  Gallagher99 replied 1 year ago.
Hi there
No worries
Kind regards ***** *****
Brian
Customer: replied 1 year ago.

Hi ordered battery on line as I have no transport then got a message that their next day delivery is only working days ,so I won't get the battery until Monday

Expert:  Gallagher99 replied 1 year ago.
Hi there ,
No worries
Kind regards ***** *****
Brian
Customer: replied 1 year ago.

OK fitted new battery and car started straight away , so that was a good cal from you Thankyou ,still intermittent speedo and trip meter PLUS is asking for the code for the radio and I have no idea what it is .Who would be able to tell me do you think ?

Expert:  Gallagher99 replied 1 year ago.
Hi there good afternoon to you
Ok that's good news that replacing the battery has confirmed my diagnostic
Ok as previously mentioned the speedo fault is most commonly down to an internal abs module issue or in rarer cases a wheel speed sensor issue
But most times it's the abs Module that loses communication with the other modules thus cannot transfers the speedo /trip information
Regarding your radio code I can give you this but will need the serial number from the audio unit
If you press 2&6 in the audio unit it should show the serial number ie: M043376
If you can post back this number I can generate your code
Kind regards ***** *****
Brian
Customer: replied 1 year ago.

Hi I thought I would need to remove the radio to get the serial number but your method gave me M033214 cheers

Expert:  Gallagher99 replied 1 year ago.
Hi there thanks
Ok here is the correct radio code you requested for serial number M033214 = 1318
If you need anymore help or advice on this issue please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day
Brian
Customer: replied 1 year ago.

Hi ,radio code worked fine thanks,only problem now is intermittent speedo function ,it goes on and off while driving and the trip meter readings sometimes stop incrementing or disappear all together then everything may start working again or not work for a few trips .The needle always gives a little kick when I start up but that is no guarantee it will function.Is there any way of establishing the problem

Expert:  Gallagher99 replied 1 year ago.
Hi there good morning to you
Ok the speedo fault you have is most commonly down to a loss of communications with the ABS module (internal fault ) (IF FITTED )
In each case I have seen this speedo issue the ABS module has needed replaced
The abs module picks up the signal from the wheel speed sensors and then calculates the speed
It then sends the data to the PCM. Which in turn sends it to the cluster
On some early fiestas they didn't have abs fitted the fault was caused by a faulty speed sensor on the gearbox
I can check if you have the abs system fitted if you can give me your registration number
Regards Brian
Customer: replied 1 year ago.

Hi reg is E55ROG was originally LR03FUW

Expert:  Gallagher99 replied 1 year ago.
Hi there
Ok your vehicle doesn't have ABS fitted therefore your issue lies with s faulty speed sends (this is located on the gearbox
The parts you require are
Speed sensor (ford part number -(###) ###-####- £48.91+ vat
Roll pin /clip (ford part number(###) ###-####- £1.68+ vat
After replacing this sensor drive the vehicle for 10-15 minutes as sometimes the speedo won't work straight after replacement (This is normal )
If you need anymore help or advice on this issue please let me know
If you are Completely satisfied with my answer /advice
PLEASE RATE MY ANSWER
Kind regards ***** ***** and have a nice day
Any postive feedback or bonuses are greatly appreciated
Brian
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3017
Experience: SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 1 year ago.

OK got those parts on order as everything else you've suggested has been 100% right so thanks for your info

What Customers are Saying:

 
 
 
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
< Previous | Next >
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P
  • Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help. Mary C.
  • This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!! Alex
 
 
 

Meet The Experts:

 
 
 
  • Matt

    Matt

    Mechanical Engineer

    Satisfied Customers:

    185
    BEng hons Mech engineering, in auto industry 22 years
< Previous | Next >
  • http://ww2.justanswer.com/uploads/35/350matt/2012-6-7_182356_matsavatr.64x64.jpg Matt's Avatar

    Matt

    Mechanical Engineer

    Satisfied Customers:

    185
    BEng hons Mech engineering, in auto industry 22 years
  • http://ww2.justanswer.com/uploads/MI/mikeamechanic/2013-4-2_175558_photo.64x64.JPG Mike Kelly's Avatar

    Mike Kelly

    Ford Mechanic

    Satisfied Customers:

    140
    17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.
  • http://ww2.justanswer.com/uploads/FO/fordspec/DSC00877.64x64.JPG fordspec's Avatar

    fordspec

    Ford Technician

    Satisfied Customers:

    11
    ford technician
  • http://ww2.justanswer.com/uploads/AL/allagher/2015-6-23_213635_image.64x64.jpg Gallagher99's Avatar

    Gallagher99

    Senior Vehicle Technician

    Satisfied Customers:

    556
    SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
  • http://ww2.justanswer.com/uploads/FO/fordtwo/2014-12-19_163422_arrepair.64x64.jpg Robert's Avatar

    Robert

    Ford Technician

    Satisfied Customers:

    41
    Fully qualified 19+yrs exp/self employed technician in the UK
  • /img/opt/shirt.png Mark's Avatar

    Mark

    Auto Service Technician

    Satisfied Customers:

    59
    Qualified City & Guilds