How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3263
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

I have engine stall problem even after both fuel pump changed..no CEL appear upon stalling

Resolved Question:

I have engine stall problem even after both fuel pump changed..no CEL appear upon stalling..it seems to be sometimes only..for long distance im confident its good except during traffic jam/junction..anything else to be considered?
After re fuel also, 1st try of starting engine will be failed..2nd or 3rd then it be good. Anyway its 2012 mondeo ecoboost 240..petrol..thanks
Submitted: 1 year ago.
Category: Ford
Customer: replied 1 year ago.
Just for info, those items been changed new:
1- o2 sensor (1pc)
2- crankshaft sensor
3- in tank fuel pump
4- high pressure fuel pump
5- cleaning throttle body & maf sensor
Besides, noticed that the fuel pressure lower (2300-2400 psi) compared to others mondeo and smax (2700-2900 psi)
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 1 year ago.
Hi
I'll be waiting for the answer.
Thank you
Expert:  Gallagher99 replied 1 year ago.
Hi there good evening to you and sorry for the delayed response Ok is there any fault codes logged in the PCM /ECU relating to low fuel flow etc Regards Brian
Customer: replied 1 year ago.
Hi.
Yes. But its intermittent..Especially after refuel..after few miles the CEL disappear..the code was p2636 fuel pump B low flow/performance..thus I decided to change the in tank fuel pump and the high pressure fuel pump as per adviced..the car feel smoother but still the engine stall 2-3 days later...besides there is sign of burnt at the fuel pump's socket during replacement
Expert:  Gallagher99 replied 1 year ago.
Hi there good morning to you and sorry for the delayed response Ok I suspect this code would be logged as I have came across similar issues on the 1.6/2.0 Ecoboost engine which at first had me suspecting fuel pump issues but looking at the complex strategy of this fuel system I found the fault lay with the low fuel pressure sensor in the engine bay These are not expensive from memory (can clarifyptove and part number if you give me your registration number ) and this only takes minutes to replace I would advise replacing this sensor to resolve your issue I have attached an image of the sensor (number 1 in image ) If you need anymore help or advice on issue please let me know If you have been completely satisfied with my answer /advice PLEASE RATE MY ANSWER Kind regards ***** ***** and have a nice dayAny postive feedback /bonuses are greatly appreciated Brian
Customer: replied 1 year ago.
Hi Brian.
Good morning..anyway thanks for your advice and yes there is something is not right with the fuel pressure as compared to others mondeo and smax (friends of mine)...can u refer to those numbers as your reference for the parts number of the sensor need to be replaced..
*WF0DXXGBBDCK22921*
By the way my mondeo spec as below:
Year: 2012
Mondeo ecoboost 2.0 (petrol) - 240ps version..1 more thing what cause the engine hard to start on the 1st time after re-fuel..is it the same cause by the fuel pressure sensor..
Thank you
Expert:  Gallagher99 replied 1 year ago.
Hi there Ok let me check this part/prove with my parts department and post back to you in a short while And yes this will cause a starting concern as the fuel pressure must be between 3.8-6.2 depending on demanded power Kind regards ***** ***** Brian
Customer: replied 1 year ago.
Thanks a lot brian..waiting for your reply
Expert:  Gallagher99 replied 1 year ago.
Thanks for your patience Ok the low fuel pressure sensor for the 2litre eco-boost 240ps engine is ford part number -(###) ###-####And is £31.75+ vat If you need anymore help or advice on issue please let me know If you have been completely satisfied with my answer /advice PLEASE RATE MY ANSWER Kind regards ***** ***** and have a nice dayAny postive feedback /bonuses are greatly appreciated Brian
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3263
Experience: SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 1 year ago.
Thanks brian