How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3263
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

I have a Ford Focus mk2 2007 with a strange problem. The

Resolved Question:

I have a Ford Focus mk2 2007 with a strange problem. The check engine light, red handbrake light, airbag light, seatbelt light temperature gage shows and lines happens intermittently while driving. The idle also dips almost to the point of stall but hasn't so far. Any idea what this could be?
Submitted: 1 year ago.
Category: Ford
Expert:  Gallagher99 replied 1 year ago.

Hi there good morning To you and sorry for the delayed response

My name is ***** ***** I would be happy to assist/ offer you advice you to today

Ok when this fault occurs does the red Immobilsor light flash or come on at the top centre of the dash

What engine is fitted to your vehicle ie:1.6 petrol

Kind regards ***** *****

Brian

Customer: replied 1 year ago.
Hey Brian,Pleasure to meet you matey. I have a video and can say that no the immobiliser light doesn't come on.Oh and it's a 1.7 petrol. I'll try and attach a picture or video for you next reply.Best
Matt
Customer: replied 1 year ago.
Picture
Expert:  Gallagher99 replied 1 year ago.

Hi Matt

Do you know if the indicators were showing on cluster when switched on

Customer: replied 1 year ago.
The indicators were not showing on the cluster when switched on.Best
Matt
Expert:  Gallagher99 replied 1 year ago.

Hi Matt thanks

Ok the first thing to check and most common cause is a loose multiplug at the fuse box /GEM module

There is a fuse box /gem module located in the passengers footwell under the glove box

Can you have a look at the two thin multiplug on The bottom of the fuse box

ensure they are clipped right home as I have had issues over the years where by one of these plugs is just not fully home and was causing similar electrical issues with the vehicle

There is a green and a brown plug ensure these are right home incase this is caused by a loose connection at the Multiplug

From memory it's the green multiplug that causes this issue

Clip this plug fully home and this will resolve your issue

If you need anymore help or advice on this issue Matt please let me know

If you are completely satisfied with my answer /advice

PLEASE REMEMBER TO RATE MY ANSWER

Kindest regards ***** ***** and have a nice day

Any postive feedback /bonuses are kindly appreciated

Brian

Customer: replied 1 year ago.
Hey Brian,Thanks for all the information, when I get back from work I'll check the passenger well fuse box for anything loose. If I have trouble could you point out the fuses/plugs if I send you a picture of it?Also is the idling dipping and almost stalling apart of the same problem or is this a different problem altogether?Best
Matt
Customer: replied 1 year ago.
Hey Brian,I think this is the manual for my car with the passenger fusebox diagram
http://www.fordservicecontent.com/Ford_Content/vdirsnet/OwnerManual/Home/Content?bookCode=O10469&languageCode=en&marketCode=GB&viewTech=IE&chapterTitleSelected=G979608&subTitleSelected=G979612&topicHRef=G876484&div=f&vFilteringEnabled=TrueBest
Matt
Expert:  Gallagher99 replied 1 year ago.

Hi Matt sorry for the delay

I have attached an image of the plugs that should be checked

Accessed from the passengers footwell

Kindest regards ***** *****

Brian

Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 1 year ago.
Hey Brian,Thank you so much! I refitted all the multiplugs with the passenger footwell fuse box and the car running amazing. The idle is perfect the warning lights are all gone it's like a new car.I'll certainly be coming here first before going to a garage in future.Thanks again Brian! Top man!
Expert:  Gallagher99 replied 1 year ago.

Hi there good afternoon to you

No worries Iam glad my assistance has helped resolve the issue

If you ever need any furture help or technical advice /assistance please let me know and I will do my upmost to assist you

Kindest regards ***** *****

Brian