How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gallagher99 Your Own Question
Gallagher99
Gallagher99, Senior Vehicle Technician
Category: Ford
Satisfied Customers: 3247
Experience:  SVQ LEVEL 3, QAULIFIED FORD SENIOR TECHNICIAN , ATA REGISTERD ,12 YEARS EXPERIENCE
17855046
Type Your Ford Question Here...
Gallagher99 is online now

I have a 08 newer type 1.6 petrol fiesta. Someone drove the

Resolved Question:

I have a 08 newer type 1.6 petrol fiesta. Someone drove the car through water and locked the engine. Inside the car was bone dry, no warning lights and engine turned but was nackered. I've fitted a replacement second hand engine but now it wont start with two warning messages appearing....airbag malfunction and electrical steering malfunction ! Ignition won't turn the engine, What will I do ??
Submitted: 12 months ago.
Category: Ford
Expert:  Gallagher99 replied 11 months ago.

Hi there good morning to you and sorry for the delayed response ,

My name is ***** ***** I would be happy to assist you today

Ok what does the Immobilsor light do when you attempt to crank the engine ,does it flash rapidly

Kindest regards ***** *****

Brian

Customer: replied 11 months ago.
Engine will not turn at all, I think because it is warning of a power steering/airbag problem. I know some people have had this problem because of a weak battery but I've taken a battery off a same model car and tried it and its fine. The wiring loom on the replacement engine hasn't been changed but its on a completely different circuit. Basically warning message on screen and refusing to engage starter.
Expert:  Gallagher99 replied 11 months ago.

Hi there have you carried out a diagnostic scan as of yet to see if the modules are responding as power steering and air bag issues shouldn't stop car from cranking

What is the red Immobilsor light in the dash doing with the ignition on

Regards ***** *****

Brian

Customer: replied 11 months ago.
when you try and crank the engine the red immobilizer engine stays on for about five seconds and then continues flashing but nothing happens
Customer: replied 11 months ago.
I Haven't carried out diagnostics scan yet. I know small warning light on instrument cluster screen won't stop engine turning, but this is on the middle screen above the radio
Expert:  Gallagher99 replied 11 months ago.

Hi there

Ok if you put the ignition on does the light go solid for around 3 seconds then go out

Does it state engine malfunction if you scroll through warming messages

Regards brian

Customer: replied 11 months ago.
No warnings about engine at all. The car was jacked up and working fine., all I've done is changed the engine
Expert:  Gallagher99 replied 11 months ago.

Can you endure the main fuses at the battety terminal incase these have blown if attempts to turn a hydrauliced engine over had occurred thus overloading these fuses at the postive terminal

Customer: replied 11 months ago.
Ive checked all the fuses in the box next to the battery and they'res no wires blown. Also checked the steering and airbag fuses in the passenger side fuse box..all good.
Expert:  Gallagher99 replied 11 months ago.

Hi there there is Mao. Fuses on the postive terminal of the battety do you have power past these fuses

Expert:  Gallagher99 replied 11 months ago.

And does the Immobilsor light stay solid then go out when ignition is turned on

Customer: replied 11 months ago.
The big fat fuse on the positive terminal is fine. All this still doesn't explain the airbag/ steering warnings?
Expert:  Gallagher99 replied 11 months ago.

The steering system and sue bag system are connected so you really need to see what codes are logged in both these modules

The water may have Ingressed into a sensor etc

Regarding the starting issue

If you remove relay r8 in the engine bay fuse box and bridge ports 3&5 does the engine crank over

Customer: replied 11 months ago.
Removed relay r8 and replaced relay from another car but doesn't work. If you want me to bridge the ports 3 and 5 is that F3 and F5?...FAN/BATTERY+ or is that r3 and r5..40 amp engine/20amp dip beam ??
Expert:  Gallagher99 replied 11 months ago.

Hi there

Ok what you need to do is remove relay r8 and bridge the ports of the fuse box where pins3&5 of the relay R8 would go this should power the starter motor and crank the engine (ignition should be on )

Customer: replied 11 months ago.
It's alive, It's alive...engine turns when I bridge these. It didn't start though.
Expert:  Gallagher99 replied 11 months ago.

Hi

Ok there is a large plug under the battety tray which is prone to water ingress this plug c11a is what carries the earth from the PCM to relay r8 ensure there are no water ingress or broken pins in this plug

Seperate and visually check and ensure its tightly fitted to the other side of the connector

Also you haven't stated what the Immobilsor light does with ignition on as it should go solid then go out (shouldn't flash )

Gallagher99 and other Ford Specialists are ready to help you
Customer: replied 11 months ago.
Hi the bottom connector was ok, however I took the plastic cover off the box bolted to the side of the battery box and the furthest of the three electrical connectors was a bit loose and needed to be pushed in! It started first time and no warnings...a bit of water coming out of the exhaust though. Thank you for your help
Expert:  Gallagher99 replied 11 months ago.

Hi there that's great news

If you ever need any future help or technical assistance with any ford vehicles please let me know and I will do my upmost to assist you

Kindest regards ***** ***** and have a nice day

Brian