How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Plumberpro Your Own Question
Plumberpro
Plumberpro, Plumber
Category: Home Improvement
Satisfied Customers: 634
Experience:  Fully qualified plumbing , heating and gas engineer 20 years experience
77408428
Type Your Home Improvement Question Here...
Plumberpro is online now

I have a baxi genesis 80 combi that wont fire. I have tested

Resolved Question:

Hi, I have a baxi genesis 80 combi that wont fire. I have tested it following the flow chart in the manual and have found that i have 0 volts to the spark generator. the chart says the reason for this is either the power board or the control board. i have changed both but still no joy. any thoughts
Submitted: 2 years ago.
Category: Home Improvement
Expert:  Plumberpro replied 2 years ago.
Hi . the boiler won't spark till the fan is proved and the pump ,flow switch or stats .
Can you hear the fan start?
Customer: replied 2 years ago.

fan is spinning, pump seems to be running, have continuity across flow switch

Expert:  Plumberpro replied 2 years ago.
Is the air pressure switch making?
Customer: replied 2 years ago.

yes

Expert:  Plumberpro replied 2 years ago.
OK , have you checked for continuity across the safety stat?
Customer: replied 2 years ago.

just tested that, ok

Expert:  Plumberpro replied 2 years ago.

Well there's not much more to test . but check the he and CH thermistors. As when these go , sometimes you get weird outcomes . look for a big change in ohms upon temperature change

Also check the water pressure switch is making and even though pressure may be right it could be blocked .

Have to come offline now . early start.

We can continue tomorrow if you like

Customer: replied 2 years ago.

im sure i've checked all the common sense stuff. this problem has occurred periodically for a while ( like once every few months ) and every time ive got it looked at the bloody thing starts, but not this time

Expert:  Plumberpro replied 2 years ago.
Well , you may have nmissed something .check the safety stat and the pressure switch. Go back over everything . make sure the board fuses are OK . I've mentioned every component apart from the PCB' s that you have changed , so I think it is going back over and rechecking everything
Plumberpro and other Home Improvement Specialists are ready to help you

Related Home Improvement Questions