How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Plumberpro Your Own Question
Plumberpro
Plumberpro, Mechanical Engineer
Category: HVAC
Satisfied Customers: 634
Experience:  Over 20 years experience in plumbing heating and gas
77408428
Type Your HVAC Question Here...
Plumberpro is online now

Remeha Avanta Plus 28 combi Showing no error codes but when

Customer Question

Remeha Avanta Plus 28 combi Showing no error codes but when boiler running for central
heating pressure builds to 4 bar opens relief valve dumps water but stays at 4 bars it would build more pressure but for the relief valve any suggestions as to the problem
Submitted: 2 years ago.
Category: HVAC
Expert:  Plumberpro replied 2 years ago.
Hi sounds like the diverter may be stuck and not opening to heating , so the water is not going round the heating circuit , but only around the boiler hot water circuit and overheating
Customer: replied 2 years ago.

central heating working ok all rads getting hot hot water working ok everything working fine apart form this over pressurizing

Expert:  Plumberpro replied 2 years ago.
Are you sure the filling loop isn't letting by?
Customer: replied 2 years ago.

yes checked that when not calling for heat pressure normal at 1.5 bar as soon as you call for heat pressure goes straight to 2.5 bar and then rises steadily to 4 bar as the temperature rises

Expert:  Plumberpro replied 2 years ago.
You say you recharge the pressure vessel . did you take it upto 1.5 bars when there was no pressure left in the system, ie drain partially.
Also was any water coming out of the pressure vessel cap ,that would indicate a tear in the balloon .
Customer: replied 2 years ago.

I depressurized the system pressurized the vessel to 1.5 bars no water came out of the cap but it did show pressure on the gauge as i pressurized the vessel

Expert:  Plumberpro replied 2 years ago.
Is it a big system ,how many rads?
Customer: replied 2 years ago.

no only 6 rads

Expert:  Plumberpro replied 2 years ago.
Hi , its got to be the expansion vessel . maybe the pipe to the expansion vessel is blocked with slide . I would check the pipe work upto date he expansion vessel for blockages .
Worse comes to worse you may have to add another one somewhere .
Plumberpro and other HVAC Specialists are ready to help you
Customer: replied 2 years ago.

ok mate thanks for your help I suspected the expansion vessel I will do a more thorough investigation

cheers John

Customer: replied 1 year ago.

Thanks again for your help checked all the pipe work changed the expansion tank as it proved to have a split in the membrane but unfortunately it has not cured the problem still building to much pressure


getting 2.5 bars at 60f and 4 bars at 75f
Expert:  Plumberpro replied 1 year ago.
Hi is the film ng loop fixed or does it have a flexible hose.undo it and make sure water isn't passing by the isolating tap. Also make sure the hose or pipe to the expansion vessel is clear