How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Hyundai
Satisfied Customers: 22154
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Hyundai Question Here...
Matt is online now

I own a Hyundai Santa fe, 2007 model, 2.2 CRD, but the

Customer Question

Hi,
I own a Hyundai Santa fe, 2007 model, 2.2 CRD, but the heater fan is stuck on full speed despite the display showing the fan speed increasing /decreasing as I push the fan speed button on the control.
I've tried to find the relay associated with the fan / blower but can only find one that is located beside the fan, underneath the glove compartment. It seems to be working ok but only switches on when the fan speed display is at the last two click ie. max speed. I disconnected the relay but it does nothing. I've also checked the switching side of the relay with a multimeter and its open ie. no permanently closed. I don't think the relay is the problem however, I think it may be the fan speed controlled due to the fact that the fan is always on as soon as I turn on the ignition, plus the fan speed is not adjustable. Can you help?
Submitted: 2 years ago.
Category: Hyundai
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 2 years ago.
Hi,
I think I have found the answer but won't know until mid week until
I get new part. Keep searching I think, if you can't find someone
By Tuesday then leave it.
Thanks
Brian
Expert:  Matt replied 2 years ago.
hello this sounds like the fan speed resistor pack may have failed, they do run quite hot so its not uncommonthe part is located under the dash and plugs into the fan cowlso I'd replace this 1st
Expert:  Matt replied 2 years ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. so if my answers have been helpful please rate my answer.