How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Jaguar
Satisfied Customers: 22247
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Jaguar Question Here...
Matt is online now

06 s type, restricted performance come up on dash and engine

Customer Question

06 s type, restricted performance come up on dash and engine cuts out
restarts no problem then cuts out again
Submitted: 3 years ago.
Category: Jaguar
Expert:  Matt replied 3 years ago.
Hello

On any car if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.



from your description this could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle pedal position sensor

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Customer: replied 3 years ago.

Hi Matt, my mechanic drove the car from a cold start and it cut out after


4 miles and again in another 2 miles, He then plugged in to a diagnostic


machine and air flow was the only fault showing, he cleared the code and


it has driven over 20 miles so far with no repeat of the problem,If it was


going in to limp mode it should not cut out so suddenly.

Expert:  Matt replied 3 years ago.
Hello Pat



I'd suggest its worth cleaning the airflow meter by removing it from the car and spraying the exposed sensor wires inside the tube with a brake or switch cleaner - ensure that the cleaner is one of the old fashioned, non Eco type that does not leave a residue

On no account touch the sensor wires with anything physical as they are extremely fragile