How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask romee619 Your Own Question
romee619
romee619, Mechanic
Category: Jeep
Satisfied Customers: 1
Experience:  Let my online troubleshooting skills speak for themselves!
61287765
Type Your Jeep Question Here...
romee619 is online now

o7 jeep grand cherokee, 3.0 crd, was driving today when all

Customer Question

o7 jeep grand cherokee, 3.0 crd, was driving today when all lights including front fog came on and the horn too continuasly. had to disconnect bty to turn everything off. any ideas ???
Submitted: 3 years ago.
Category: Jeep
Expert:  Shantal-Mod replied 3 years ago.
Hello,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you,

Shantal
Expert:  indy-tech replied 3 years ago.
Name is Greg, My goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,

Hi are you still in need of assistance with this problem .

Sorry that we are late in getting to you there must be a technical issue

Rgds Greg
Customer: replied 3 years ago.

Hi, problem with jeep has changed, after disconnecting bty the light and horn problem has stopped, but now there seems to be another problem.There seems to be an interuption in power to car stereo and a few warning lights on dash come on but then go off again just as quick. rev counter and speedo also effected same time but no effect on engine power. slight clicking noise before all this happens.

Expert:  indy-tech replied 3 years ago.
Hi .

Please check the battery connection are very clean rub the post and clamps down with sand paper reconnect and check .

Also check the ground cable from the battery to the chassis then engine block.

Greg
Customer: replied 3 years ago.

done all bty checks as well as ground cables.checked all relays and fuses.not all dash lights come on, mainly stability and traction as well as power loss to rev counter and speedo

Expert:  indy-tech replied 3 years ago.
Check for malfunction codes .

Check with running engine alternator output voltage .

Greg