How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask indy-tech Your Own Question
indy-tech
indy-tech, Technician
Category: Jeep
Satisfied Customers: 7065
Experience:  Jeep tech ,
29331485
Type Your Jeep Question Here...
indy-tech is online now

New abs pump fitted, now get grating noise and vibration in

Resolved Question:

New abs pump fitted, now get grating noise and vibration in
pedal occationally when braking
Submitted: 2 years ago.
Category: Jeep
Expert:  indy-tech replied 2 years ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,

Is the ABS warning light still ON when the engine is running and driving .

Greg
Customer: replied 2 years ago.

Greg, the abs warning night goes out when engine is running. The grating noise appears to happen only at low speed braking when the pedal is nearly fully depressed. Brakes are working perfectly otherwise. Hope this helps, thanks. Stan

Customer: replied 2 years ago.

Greg, further to last answer, noise does not happen each time I brake only intermittant. But when it does it happens when braking from normal speed and occurs at about 20 mph.Hope this helps. Here's hoping this helps. Regards Stan

Expert:  indy-tech replied 2 years ago.
Hi Stan .

Check for malfunction codes looks like you have a bad wheel speed sensor .

Remove the ABS fuse and test drive if the issue disappearthen you have a malfunction in the system like a speed sensor . hook up a ABS scan tool and check for codes .

Get back to me with what you find .

Rgds Greg
Customer: replied 2 years ago.

Greg, Thanks for info, EXCELLENT service. I'm going on holiday to-night, will get back to you when I get back. Stan

Expert:  indy-tech replied 2 years ago.
Hi Stan .

Have a great Holiday.

Make the best of it wish you all th best .

Rgds Greg
Customer: replied 2 years ago.

Greg,Just back holiday 0 th

Customer: replied 2 years ago.

Greg, thanks for your response, did as you suggested, turned out to be dirty sensor o/s back wheel. Everything seems to be ok now, fingers crossed. Stan. I Rate you answers as excellent and some. All the best.

Expert:  indy-tech replied 2 years ago.
Hi Stan .

thank you and all the best .

Please rerate as nothing came though.

Kindest regards Greg
indy-tech and other Jeep Specialists are ready to help you

Related Jeep Questions