How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mazda
Satisfied Customers: 22250
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mazda Question Here...
Matt is online now

I have an MX 5 on an X plate and it keeps breaking down when

Customer Question

I have an MX 5 on an X plate and it keeps breaking down when it's a hot day. She stalls and then won't start until she's cooled down. Its not a temperature issue and I really feel its a fuel problem. If any could help that would be great.
Submitted: 1 year ago.
Category: Mazda
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I apologize as we have not yet been able to find a Professional to assist you. Do
you wish for me to continue to search for someone to assist you or would you
like for us to close your question at this time?
Thank you for your patience,
Shantal
Expert:  Matt replied 1 year ago.

Hello

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

unplug each in turn and use some switch / contact cleaner spray on the pins to ensure its all grease / dirt free

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:

http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Expert:  Matt replied 1 year ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you