How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Mercedes Technician
Category: Mercedes
Satisfied Customers: 39198
Experience:  Tech Expert
9261905
Type Your Mercedes Question Here...
Mike is online now

Hi - My 2001 petrol ML500 coolant warning light is now illuminated

Customer Question

Hi - My 2001 petrol ML500 coolant warning light is now illuminated and coincidentally the heated seats have stopped working, (which according to the experts is correct as the items are connected!). It has been established that the water level is ok and that power reaches the cooling fan assembly but the fan wont cut in when needed. I would rather not spend £1000.00 on a new unit!! Any ideas? Thanks. Bob. PS As a matter of interest, around the same time my mechanic replaced indicator/brake bulbs with LEDs and had to fit little regulators to each one to stop them quick flashing! Thanks Bob
Submitted: 4 years ago.
Category: Mercedes
Expert:  Walt-mod replied 4 years ago.
Hi,
I'm a moderator for this topic. I've been working hard to find a Professional to assist you right away, but sometimes finding the right professional can take a little longer than expected.
I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.
Thank you!
Customer: replied 4 years ago.

Hi Walt - yes I'm fine waiting and I'm hoping that your expert's answer is going to be worth waiting for!!


Cheers,


Bob.

Customer: replied 4 years ago.

Yes I'm happy to wait - but the value of your service is diminishing!!

Expert:  Mike replied 4 years ago.
Hello and Welcome to justanswer..

My name is MIKE - Im happy to help / advise you with this issue.

Before we progress - please tell me , I note you mention the bulbs having been replaced.... I need you to check / have checked, that each one is indeed correct - the exact / proper / correct bulb fitted in each unit - -

Plus - have any plug in diagnostic tests been carried out - and if so, what were the results of that - fault codes?

Kind Rgds, MIKE...............................
Customer: replied 4 years ago.

Hi Mike - bulbs were fitted by my mechanic and as far as I know bulb fitment is correct, they all work properly, seem to be the correct brightness and flash at the appropriate rate. Yes, plug in tests have been done and show faults with engine cooling fan, heated seats and front middle left park sensor, (which was known about earlier), but I dont have the codes, sorry! All fuses have been checked, (inc the one on the battery terminal!), and my mechanic is pretty sure that he can establish that power is reaching the fan motor ok but when isolated and connected to an independant power source that it wont turn.


looking forward to hearing from you. Hopefully with good news!


Cheers,


Bob

Expert:  Mike replied 4 years ago.
Hello again Bob..

Thank you for your reply and info there..

It is normal for resistors to have been fitted on the LED installation - I'll just mention that -and that has nothing to do with this issue.

Im afraid that your mechs tests re the fan unit do narrow it down to that - if the fan wont turn when independenty powered, the fan unit has failed and needs to be replaced.

This will cause your cooling system issues so that needs doing before anything else. I have to say Im not fully sure that the seat issue is connected, that will need manually tracing / checking through -but that is definitely your issue with the cooling system...

Let me know if you need anything else on this - If you do get back to me wishing to discuss it further- I will get back to asap after I receive your reply.

Meantime -- Please click on the OK rating to Excellent ratings service for me now, Thank you for that... and you can get back to me anytime if you need / wish..

Best Rgds, MIKE.


Please note, you are rating the content of my "answer" - my help to you - not the "system" which can experience delays etc which are not under my personal control -or delays caused by "time -off" which we all have on occasion - Thank you.
Customer: replied 4 years ago.

I'm very disapointed with your reply, my question was suposed to be answered by a "Expert" so far you've told me only what I've already been told!! I'm expecting you to know more than those I've already spoken to. I want to know alternative repair solutions other than just spending £1000.00 on a full fan unit replacement. Also if you say that the heated seat problem isn't connected, (when others say it is), I would expect a detailed explanation as to all the possible causes and guidance as to how to fix it, not a generalised comment about manuall tracing. This has not been good value for money.

Customer: replied 4 years ago.
Relist: Answer quality.
I'm very disapointed with the reply, my question was suposed to be answered by a "Expert" so far I've been told me only what I've already been told!! I'm expecting you to know more than those I've already spoken to. I want to know alternative repair solutions other than just spending £1000.00 on a full fan unit replacement. Also if you say that the heated seat problem isn't connected, (when others say it is), I would expect a detailed explanation as to all the possible causes and guidance as to how to fix it, not a generalised comment about manuall tracing. This has not been good value for money.