How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Mike Your Own Question

Mike, Mercedes Technician
Category: Mercedes
Satisfied Customers: 39198
Experience:  Tech Expert
Type Your Mercedes Question Here...
Mike is online now

2006 311CDI Sprinter. Recently been having problems starting

Customer Question

2006 311CDI Sprinter. Recently been having problems starting 1st time. Engine seems to be seeking an even running speed, then cuts out. On second start, all is OK. Sometimes it starts 1st try. Yesterday it started 1st time when I went out and for the return trip (just a few miles). Went back outside to put it away and accidentally turned the key all the way without waiting for the lights to go out and it didn't start. Tried again (properly) but it would not turn over. On 3rd attempt it started. Moved the van forward a few yards to get wife's car out of the way. Tried starting van again but it won't turn over. Other electrics appear OK. Please help. Would disconnecting battery and reconnecting help to reset any relays? When I turn ignition off I can hear a high pitch faint noise which stops eventually. Also when the dash-board lights go out, there is 1 symbol that stays on - a little picture of an engine in orange.

Submitted: 3 years ago.
Category: Mercedes
Expert:  Mike replied 3 years ago.
Hello and Welcome to justanswer...

As there has been a delay - please let me know if you still need help with this -

If so - please tell me exactly what's been done meantime -

Rgds, MIKE.......................................
Customer: replied 3 years ago.


While I was waiting for a response, I did a bit of investigation in the operating manual that comes with the van. I found that there is a button marked as 'Reset' on a picture of the dashboard. It has a '0' on it and is to the left of the speedo. The manual referred to a page number for this Reset button but when I got to the page it didn't tell me anything about the button. It just told me that it was one of the things that would cause the central display to illuminate. Not much help! Anyway I thought I would try pressing and holding it in. I think I did it first without the ignition on. Still no joy with starting. Then I think I tried it with the ignition on. Then I tried again and it turned over and started 1st time. I have stopped and started the engine several times without problems. Perhaps my problem has gone away. One strange thing I have noticed the last time I started it was that the screen for my reversing camera is now not working. I don't believe in coincidences so perhaps there is some underlying electrical problem. Hopefully just a blown fuse, but I will investigate this in the morning.

Expert:  Mike replied 3 years ago.
Hello again John - Thank you for your reply...

Ok - let me know how you get on this morning with your checks etc.

Re the reverse camera , I would suspect that too to be honest so you will need to check that in any case.

With your initial description of the faults, this tended to lead me toward battery / connection and relay issues ( main relay ) but see how you get on and you are welcome to come back to me here anytime..

Best Rgds, MIKE.
Customer: replied 3 years ago.

Thanks. I now have a working rear-view monitor. I checked it's fuse which didn't appear to be good when I first got it on the bench and then after fiddling with it, it was OK. When I put it all back together it worked fine.

Battery connection issues I can deal with. However, which one is the 'main relay'? How do I test it? I do not understand how either of these problems would explain the problem I was having where on the 1st start it was searching for a good idle and then on subsequent start everything was fine.

Expert:  Mike replied 3 years ago.
Hi again John -

Im glad things are progressing well...

Can you give me the Full reg - and the VIN too if you can and I'll check for sure on that for you..

Best Rgds, MIKE.............................
Customer: replied 3 years ago.

Reg No is: KR56 OMO

VIN is: WDB9066352S136530


I forgot to mention earlier that although I now have a working rear-view monitor it is still not starting 1st time. 2 or 3 times today I turned the key but the engine did not turn over. And the first time I started it, it was doing the searching for an idle thing.

Expert:  Mike replied 3 years ago.
Hello there John - Thank you for your message -

Just one more thing then given that extra info re the starting you mention above - when you turn the key to start - and it wont.... what exactly is happening.... any noises etc... does the engine spin / turn..or not etc ?

Rgds,. MIKE....................................

What Customers are Saying:

  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
< Previous | Next >
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, do indeed know your stuff. Jim
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P
  • Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help. Mary C.
  • This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!! Alex

Meet The Experts:

  • Matt


    Mechanical Engineer

    Satisfied Customers:

    BEng hons Mech engineering, in auto industry 22 years
< Last | Next >
  • Matt's Avatar


    Mechanical Engineer

    Satisfied Customers:

    BEng hons Mech engineering, in auto industry 22 years
  • Marty's Avatar


    ASE Certified Technician

    Satisfied Customers:

    Bosch Certified Master Technician with over 35 years experience in the automotive industry.
  • mike_a_mechanic's Avatar


    Mercedes Mechanic

    Satisfied Customers:

    17 years experience as a auto mechanic, foreign and domestic.5 years running my own repair business.
  • MB Paul's Avatar

    MB Paul

    Mercedes Technician

    Satisfied Customers:

    Mercedes Benz Qualified Diagnostic Technician
  • Greg's Avatar



    Satisfied Customers:

    Automotive diagnostic tech
  • Ross's Avatar


    Diagnostic and repair technician

    Satisfied Customers:

    Licensed diagnostic and repair technician