How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 53945
Experience:  Bosch Certified Master Technician with over 35 years experience in the automotive industry.
13230946
Type Your Mercedes Question Here...
Marty is online now

i have just changed a bulb in the dashboard of my slk r170

Customer Question

i have just changed a bulb in the dashboard of my slk r170 (2000) and now nothing works in the cluster it is though eveything is dead even the speedometer does not work ,At least the engine starts and runs ,one thing strange happens the cooling fan starts and runs straight away ,it appears as though it should reset
Submitted: 4 years ago.
Category: Mercedes
Expert:  Marty replied 4 years ago.

eurotec :

Hi, and welcome. My name is Marty. It sounds as though you may not have fully seated the connectors to the cluster. I would first check all of the fuses and make sure none are blown then I would remove the cluster and recheck the connections.

eurotec :

Fuse 3 and 37 power the instrument cluster.

eurotec :

Let me know if you need more help with this.

Related Mercedes Questions